Cisco ASA 5505 - 5512 series: S2S VPN Tunnel setup guide

I need to build S2S tunnels on 4 ASAs of different models and IOS versions. Is there a sure-fire guide out there that includes troubleshooting tips?
LVL 1
d4nnyoAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Pete LongTechnical ConsultantCommented:
Ive got a ton of walk throughs

for troubleshooting just type VPN troubleshooting into the search at the top :)

Pete

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
d4nnyoAuthor Commented:
Pete, I tried to follow your instructions but my tunnel doesn't work. Can you help?

Additionally, I've lost remote VPN Cisco IPSEC client access to the firewall HH50, below.

Below are the two san-o-tized configs. (The public IPs are fake.) All suggestions welcome.

: Saved
:
ASA Version 8.4(5)
!
hostname HH70
enable password encrypted
passwd  encrypted
names
!
interface Ethernet0/0
 switchport access vlan 2
 speed 100
 duplex full
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.64.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 20.90.200.50 255.255.255.248
!
boot system disk0:/asa845-k8.bin
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
object network obj-192.168.12.0
 subnet 192.168.12.0 255.255.255.0
object network obj-192.168.39.0
 subnet 192.168.39.0 255.255.255.0
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object network obj-192.168.64.0
 subnet 192.168.64.0 255.255.255.0
object network cam-server
 host 192.168.64.241
object network cam-server-Priv
 host 192.168.64.241
object service 8200-8203
 service tcp source range 8200 8203
object network cam-server-Public
 host 20.90.200.50
object network HH70-SN
 subnet 192.168.64.0 255.255.255.0
object network HH50-SN
 subnet 192.168.24.0 255.255.255.0
object-group network security-system
 network-object 69.74.140.224 255.255.255.224
 network-object 65.244.124.224 255.255.255.240
 network-object 65.51.17.0 255.255.255.0
object-group network alarm-system
 network-object host 20.90.200.50
object-group service security-protocol tcp
 port-object range 2001 2002
object-group service cam-protocol tcp
 port-object range 8200 8203
object-group network cam-system
 network-object 65.51.17.0 255.255.255.0
object-group network cam-sys
 network-object host 20.90.200.50
access-list no-nat extended permit ip 192.168.64.0 255.255.255.0 192.168.39.0 255.255.255.0
access-list split-tunnel extended permit ip 192.168.64.0 255.255.255.0 192.168.39.0 255.255.255.0
access-list outside_access_in extended permit icmp any any echo-reply
access-list outside_access_in extended permit tcp any interface outside eq 2001
access-list outside_access_in extended permit tcp any interface outside eq 2002
access-list outside_access_in extended permit tcp any interface outside eq 8200
access-list outside_access_in extended permit tcp any object-group cam-protocol object-group cam-sys
access-list outside_access_in extended permit tcp any object cam-server-Priv range 8200 8203
access-list VPN-INTERESTING-TRAFFIC extended permit ip object HH70-SN object HH50-SN
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VPNPool 192.168.39.100-192.168.39.120 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (inside,any) source static obj-192.168.12.0 obj-192.168.12.0 destination static obj-192.168.39.0 obj-192.168.39.0 no-proxy-arp route-lookup
nat (inside,any) source static obj-192.168.64.0 obj-192.168.64.0 destination static obj-192.168.39.0 obj-192.168.39.0 no-proxy-arp route-lookup
nat (inside,outside) source static cam-server-Priv interface service 8200-8203 8200-8203
nat (inside,outside) source static HH70-SN HH70-SN destination static HH50-SN HH50-SN no-proxy-arp route-lookup
!
object network obj_any
 nat (inside,outside) dynamic interface
object network cam-server
 nat (inside,outside) static interface service tcp 8200 8200
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 20.90.200.40 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
http 192.168.12.0 255.255.255.0 inside
http 192.168.39.0 255.255.255.0 inside
http 192.168.64.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 1 match address VPN-INTERESTING-TRAFFIC
crypto map outside_map 1 set pfs
crypto map outside_map 1 set peer 20.90.100.100
crypto map outside_map 1 set ikev1 transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto ikev1 enable outside
crypto ikev1 policy 10
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 20
 authentication rsa-sig
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 40
 authentication crack
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 50
 authentication rsa-sig
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 60
 authentication pre-share
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 70
 authentication crack
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 80
 authentication rsa-sig
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 90
 authentication pre-share
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 100
 authentication crack
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 110
 authentication rsa-sig
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 120
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 130
 authentication crack
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 140
 authentication rsa-sig
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 150
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh 192.168.39.0 255.255.255.0 inside
ssh 192.168.12.0 255.255.255.0 inside
ssh 192.168.64.0 255.255.255.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 15
ssh version 2
ssh key-exchange group dh-group1-sha1
console timeout 0
management-access inside

dhcpd auto_config outside
!
dhcpd address 192.168.64.100-192.168.64.130 inside
dhcpd dns  interface inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy DfltGrpPolicy attributes
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value split-tunnel
username privilege 15
tunnel-group general-attributes
 address-pool (outside) VPNPool
tunnel-group ipsec-attributes
 ikev1 pre-shared-key *****
tunnel-group 20.90.100.100 type ipsec-l2l
tunnel-group 20.90.100.100 ipsec-attributes
 ikev1 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:d08d43859c94ea66852cb516915a2746
: end
no asdm history enable

**************************************************************

ASA Version 9.1(2)
!
hostname HH50
enable password encrypted
names
ip local pool VPNPool 192.168.199.100-192.168.199.200 mask 255.255.255.0
!
interface GigabitEthernet0/0
 description Fiber connection
 nameif ISP1
 security-level 0
 ip address 20.90.100.100 255.255.255.248
!
interface GigabitEthernet0/1
 nameif ISP2
 security-level 0
 ip address 255.255.255.252
!
interface GigabitEthernet0/2
 description inside
 nameif inside
 security-level 100
 ip address 192.168.24.1 255.255.255.0
!            
interface GigabitEthernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/4
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/5
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 management-only
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!            
boot system disk0:/asa912-smp-k8.bin
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
object network obj-192.168.24.0
 subnet 192.168.24.0 255.255.255.0
object network obj-192.168.199.0
 subnet 192.168.199.0 255.255.255.0
object network HH50-SN
 subnet 192.168.24.0 255.255.255.0
object network HH70-SN
 subnet 192.168.64.0 255.255.255.0
access-list split-tunnel extended permit ip 192.168.24.0 255.255.255.0 192.168.199.0 255.255.255.0
access-list ISP1_access_in extended permit ip object obj-192.168.199.0 any
access-list inside_access_in extended permit ip object obj-192.168.199.0 any
access-list inside_access_in extended permit ip object obj-192.168.24.0 any
access-list VPN-INTERESTING-TRAFFIC extended permit ip object HH50-SN object HH70-SN
pager lines 24
logging asdm informational
mtu ISP1 1500
mtu ISP2 1500
mtu inside 1500
mtu management 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-713.bin
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (inside,ISP1) source static obj-192.168.24.0 obj-192.168.24.0 destination static obj-192.168.199.0 obj-192.168.199.0 route-lookup
nat (inside,ISP1) source static HH50-SN HH50-SN destination static HH70-SN HH70-SN no-proxy-arp route-lookup
!
nat (inside,ISP1) after-auto source dynamic any interface
nat (inside,ISP2) after-auto source dynamic any interface
access-group ISP1_access_in in interface ISP1 control-plane
access-group inside_access_in in interface inside control-plane
route ISP1 0.0.0.0 0.0.0.0  1 track 1
route ISP2 0.0.0.0 0.0.0.0  254
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 management
http 192.168.24.0 255.255.255.0 inside
http 192.168.199.0 255.255.255.0 ISP1
http 192.168.199.0 255.255.255.0 inside
http 0.0.0.0 0.0.0.0 ISP1
http 0.0.0.0 0.0.0.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
sla monitor 123
 type echo protocol ipIcmpEcho 24.97.204.105 interface ISP1
 num-packets 3
 timeout 3000
 frequency 5
sla monitor schedule 123 life forever start-time now
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association pmtu-aging infinite
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map ISP1_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map ISP2_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map ISP2_map interface ISP2
crypto map outside_map 1 match address VPN-INTERESTING-TRAFFIC
crypto map outside_map 1 set pfs
crypto map outside_map 1 set peer 20.90.200.50
crypto map outside_map 1 set ikev1 transform-set ESP-3DES-SHA
crypto map outside_map interface ISP1
crypto ca trustpool policy
crypto ikev1 enable ISP1
crypto ikev1 enable ISP2
crypto ikev1 policy 10
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 20
 authentication rsa-sig
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 40
 authentication crack
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 50
 authentication rsa-sig
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 60
 authentication pre-share
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 70
 authentication crack
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 80
 authentication rsa-sig
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 90
 authentication pre-share
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 100
 authentication crack
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 110
 authentication rsa-sig
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 120
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 130
 authentication crack
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 140
 authentication rsa-sig
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 150
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
!
track 1 rtr 123 reachability
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 ISP1
ssh 192.168.24.0 255.255.255.0 inside
ssh 192.168.199.0 255.255.255.0 inside
ssh 192.168.1.0 255.255.255.0 management
ssh 0.0.0.0 0.0.0.0 management
ssh timeout 5
ssh version 2
ssh key-exchange group dh-group1-sha1
console timeout 0
management-access inside
dhcpd address 192.168.24.100-192.168.24.200 inside
dhcpd dns 24.29.99.35 24.29.99.36 interface inside
dhcpd enable inside
!
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ssl encryption rc4-sha1 aes128-sha1 aes256-sha1 3des-sha1
group-policy DfltGrpPolicy attributes
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value split-tunnel
username privilege 15
tunnel-group DefaultRAGroup general-attributes
 address-pool (ISP1) VPNPool
tunnel-group DefaultRAGroup ipsec-attributes
 ikev1 pre-shared-key *****
tunnel-group 20.90.200.50 type ipsec-l2l
tunnel-group 20.90.200.50 ipsec-attributes
 ikev1 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:25777cfa5b663ac36522488bb069c9df
: end
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.