Excel spreadsheet won't sort all columns together

Hello.  We have a spreadsheet from one of our users, where he added 3 columns (N,O,P) onto the existing sheet, and while they look like the rest of the columns, there's something about them that will not allow N,O,P to be sorted along with the rest of the worksheet.  A thru M can be sorted, and N-P - but not ALL together...the SORT function becomes greyed out if you try.  I want to try and resolve this without attaching the file, if possible (sensitive info).  if absolutely necessary, I can create an abbreviated version of it perhaps.  

thank you in advance
Damian_GardnerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dave BaldwinFixer of ProblemsCommented:
Make up a simple version that you can post that demonstrates the problem.  That will give us something to work with.  Otherwise, we're just guessing.
0
MagaduCommented:
Is it possible that your data is formatted as a table and these additional columns are just a range?

Edit: If you try to sort Range and Table together Sort will be grayed out.
0
Damian_GardnerAuthor Commented:
Ok - I figured.  here you go.  

Yeah - I'm not sure if its a mix of table and range, actually.

thanks guysCopy-of-2016---Airgas.xls
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

tomfarrarCommented:
These guys have the answer:

Steps are:

Click inside the data table
Go to Table Tools Menu (above the normal menus)
Go to resize table (underneath the table name on the far left)
Change table to include the three new columns
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Damian_GardnerAuthor Commented:
Ok - it says I need to remove AutoFilters before I can do that.  I'll see if I can find where that's set...
0
Damian_GardnerAuthor Commented:
I found it.  had to turn off autofilters for both sections, and now I can sort.  thank you gentlemen!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Spreadsheets

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.