Disable hardware acceleration in Office

I'd like to disable hardware graphics acceleration in Microsoft Office 2013 for all end users (Windows 7).  I have changed this setting in group policy according to the Microsoft KB article (https://support.microsoft.com/en-us/kb/2768648) under User Configuration > Administrative Templates > Microsoft Office 2013 > Miscellaneous > Do not use hardware graphics acceleration - "Enabled".  However, the settings are not being applied.  When I run gpresult on the client I can see the correct policy being applied to the workstation, and gpreport shows the setting, although it says the display name can't be found:

gpreport
Is it normal to display that way?  This is my first time using ADMX files so I'm not sure.  Is there something I could have done wrong implementing the ADMX files?  Why is the setting appearing as though it's set, but when I open any Office program and go to File > Options > Advanced > Display, the "Disable hardware graphics acceleration" checkbox is not marked?
fallriverelectricAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Davis McCarnOwnerCommented:
You have to reboot the workstation for the setting to be applied.  Have you done so?

You can query the value with REG.exe Query HKCU\Software\Microsoft\Office\15.0\Common\Graphics /V DisableHardwareAcceleration in a CMD window.

As to your gpreport image, I suspect that any of the policies you haven't set are not in the user's registry and that is what the message means.
0
fallriverelectricAuthor Commented:
I have tried rebooting the workstation, and running the query you suggested returns "ERROR: The system was unable to find the specified registry key or value."  Why is the policy appearing as though it's being applied, and shows up in gpreport, but not in the registry?
0
Davis McCarnOwnerCommented:
Did you login as the same user?  Both the policy and the reg query are for the current user.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

fallriverelectricAuthor Commented:
Yes, it's the same user.
0
Davis McCarnOwnerCommented:
If you go and manually change it in Office, does it stick or go away when you reboot?
0
fallriverelectricAuthor Commented:
It sticks.
0
Davis McCarnOwnerCommented:
Delete the key, reboot, and try this in a CMD prompt: REG.exe Add HKCU\Software\Microsoft\Office\15.0\Common\Graphics /T REG_DWORD /V DisableHardwareAcceleration /D 0x1  /F
if that works, we can either try to figure out what is wrong with your GPO's or add it to a login script and call it done.
0
fallriverelectricAuthor Commented:
Adding the value to the registry did check the box inside Office.  I'd really prefer to use GPO rather than login script.  I know other settings in the same GPO are being applied, so I keep thinking it must be something to do with ADMX.  Is there a wrong way to implement this?
0
Davis McCarnOwnerCommented:
And you have fully updated both the server and ADMX?
0
fallriverelectricAuthor Commented:
I guess I don't know.  What do I need to check for?  I am able to see the MS Office settings inside GP Editor, so I assumed it was updated.
0
Davis McCarnOwnerCommented:
In the server's control panel, do Windows Update.
What version is the server?
0
fallriverelectricAuthor Commented:
Ah sorry, didn't realize you meant Windows Updates.  They are up to date.  The server is 2012 R2 Standard.
0
footechCommented:
I would expect the GP setting to appear that way only when the .ADMX file isn't available.  Are you using a central store for GP?

Since this is a user setting, is the GPO being applied to an OU with user accounts?  And the security filtering applied to a group of users ("authenticated users" is fine) as well?
0
fallriverelectricAuthor Commented:
No, I don't think we are using a central store.

Yes, it's being applied to an OU with user accounts, with the security filtering of authenticated users.
0
footechCommented:
In that case you probably don't have the .ADMX file on the machine you opened the GPMC (Group Policy Management Console).  I say GPMC because the screenshot looks like that vs. from an HTML file generated by gpresult (feel free to correct me if I'm wrong).  However, that's just a display issue.

You've mentioned gpreport a couple times.  Did you mean gpresult.exe, or the GP Results Wizard inside GPMC?  If you've used one, try the other to see if it gives different results.  I can't see how it would, but I'm curious if running from a remote machine would give different results compared to running locally.  Lastly, I'm wondering if GP is being refreshed by your machine properly.  If you make a change to the GPO (something not Office related), does it get picked up?

The .ADMX and .ADML files really don't come into play (as far as how GP is processed by a client) after the setting has been set.
0
fallriverelectricAuthor Commented:
Yes, I ran the command gpresult /h gpreport.html from the client.   GPMC shows the same:

GPMC
As a test, I just updated the setting "prevent changing desktop background" to enabled, then ran "gpupdate" on the client, and could see the setting being enforced.  Removed it and again saw the change.  So other stuff does appear to be working fine.
0
footechCommented:
Well, the screenshot from GPMC looks different (correct).

Have you tried removing the setting from the GPO, close it, then re-add the setting?  Sorry, can't think of anything that would cause a single setting within a GPO to not apply, while the others do.
0
fallriverelectricAuthor Commented:
Just tried that, and unfortunately it's a no-go.  I can't help but feel it's related to the ADMX somehow.  Can you tell me the proper way to implement these templates?  At the time I added them, I felt there wasn't very specific instructions on where to put them or how to do it, and I may have done something wrong.
0
footechCommented:
All you do is copy the .ADMX files into %systemroot%\PolicyDefinitions (and the .ADML files into the appropriate language subfolder like "en-us").

The Group Policy editor will use everything it finds in PolicyDefinitions automatically.
0
fallriverelectricAuthor Commented:
The download on Microsoft's site (http://www.microsoft.com/en-us/download/details.aspx?id=35554) has a 32-bit version as well as a 64-bit version - what if I have some users on each version?  The ADMX file names are the same, how can I use both?
0
footechCommented:
The .ADMX and .ADML files for both packages are the same, so it doesn't matter which you use.  The only difference in the packages are the .DLL files, which I think are used by the OCT (something I have no experience using).

Try this query.
REG.exe Query HKCU\Software\Policies\Microsoft\Office\15.0\Common\Graphics /V DisableHardwareAcceleration

Open in new window

0
fallriverelectricAuthor Commented:
Here's the output of that query.  

query
0
footechCommented:
In that case, it looks like the GPO setting is being applied (that's the registry setting it changes).

I can't see how Office wouldn't pick it up if it is there.  Are you sure you're using Office 2013?
0
fallriverelectricAuthor Commented:
Yep, I'm positive.  

office version
0
footechCommented:
It appears the GPO setting is being applied to the registry, so it's just up to Office to act on it.

Have you looked on other machines to see if the setting is active?
Maybe do a repair of the Office installation.

Beyond that, I'm out of ideas.
0
fallriverelectricAuthor Commented:
I've checked a few other machines, and it isn't being applied to any of them.  One of the ones I checked just had a repair done on it within the past week or two, and it also doesn't have the setting active.  

Kind of strange.  I appreciate all the help though!
0
footechCommented:
I have this exact same setting applied in my environment, and I never had any trouble with it.

Just did a Google search and came up with some interesting results.  It appears that not all versions of Office 2013 work with Group Policy.  See the following:
https://community.spiceworks.com/topic/373897-gpo-not-applying-to-oem-office-2013
https://technet.microsoft.com/en-us/library/cc179176.aspx
-excerpt -
You can use Group Policy to manage the following versions of Office 2013:
•Office suites available through volume licensing. For example, Office Standard 2013.

•Individual Office programs sold through retail stores or through volume licensing.

If you buy Office as part of Office 365, your license plan determines whether you can use Group Policy to manage your Office programs. The Office Applications Service Description lists which Office 365 plans support Group Policy.

Where/how did you obtain Office 2013?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
fallriverelectricAuthor Commented:
We purchased a downloadable copy online, so it's OEM.  That's unbelievable.  Thanks for finding it and for all the troubleshooting help!
0
footechCommented:
Personally I think Microsoft deserves a swift kick in the nuts for a practice like this.  I could possibly see restricting certain editions (like a Starter edition) from working with GP, but it shouldn't matter in the least whether the product is OEM, retail, or volume licensed.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.