High Latency on Hyper-V server

Hello all,

I am seeing high latency tracert from a VM. over 150ms up to about 200ms. Tracing to a PC on the same network.

The topology is one Cisco 3650 Switch and of course the Hyper-V server, Dell R730. I have tried chimmey off load, Turning off VMQ, Isolating network interfaces, no matter what can not get the ping to go down.

Thoughts?
SearsFranchisesITAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MPCP-BrianCommented:
I have seen this issue on some Dell servers when both the host and virtual machine are allowed to use the virtual NIC. To ensure this is not the issue allow only one or the other to use the NIC and see if this clears up the issue (has for me on certain models)

Also - update the drivers. If you can update them from the manufacturer instead of Dell. (Broadcom, Intel, etc.)

It was related to a feature of the NIC that is not highly advertised - If this worked for you I will check my notes when I get home to see if I can track down the name of the feature so you can research which NICs may be affected.
0
SearsFranchisesITAuthor Commented:
Brian-
thanks for the response. Here's my retort. :) I have 24 ports in these servers, all use LACP for different networks. This network that is causing issues is a etherchannel using 2 ports on a 4 port card. The other 2 ports are fine, the driver was updated to the latest tonight, thanks for the advice, :)

I am not real clear on your first comment, in looking at the config it does not look like the host is using the virtual nic?

Thanks in advance for any additional assistance.

--john
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
How are the ports teamed? Natively or via the vendor's tools?
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

SearsFranchisesITAuthor Commented:
Native though Windows 2012 R2 LACP with Cisco Switches at the other end.

I may have found the issue, that being VMQ enabled on the physical interfaces. I will report if that was the fix.

Thanks,
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Broadcom NICs. They're bad. They are supposed to disable VMQ on Gigabit NICs by default.

NOTE: If the driver gets updated those settings may get reset. Verify them after!

EDIT: Also, in 2012 R2 the preferred native teaming method is the Default. LACP can introduce headaches.
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
You can close as per your assigned points without intervention. :)
1
SearsFranchisesITAuthor Commented:
Offloads need to be shut off  as well as VMQ
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hyper-V

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.