iphone will not send emails with large attachments

When trying forward an email message with a 13 MB attachment, it never sends and I receive the error -
Cannot send mail
An error occurred while delivering this message
Email is on an Exchange 2007 server and active sync policy has attachment size as unlimited

I am also seen event ID 1008 - exception occurred and was handled by Exchange ActiveSync.  I removed email from the phone, removed the partnership on the server and disabled active sync for this user.  I then enabled ActiveSync, added the email account back on the phone and it is still not working.

Any suggestions?
WPLGAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MPCP-StewartCommented:
This happened to me before.

This is what I did to make it work:

Go to the user in Active directory, and under permissions, make sure Inherit from Parent Object was checked.  

Checking that made it so everything, including large emails, would send correctly.
0
WPLGAuthor Commented:
We are running Windows Server 2012 Active Directory.  I see "security" and not "permissions" and I am not exactly sure where to check "inherit from parent object" is in this version.  When I click on advanced the only option I have is to "disable inheritance".  Should I assume it is already enabled?
0
MPCP-StewartCommented:
Correct.

There is one more thing to check if this happens from any iOS device.

If you look further down into the Event ID you might find text saying "Maximum Request Length Exceeded under the Exception Message"

if you do, it means this  is due to the Max Request Length setting (in Exchange) being 10MB by default.

If it isn't changed from the default:

On the server, browse to the web.config file (under the ClientAccess\Sync folder)
Open the web.config file
Modify the <httpRuntime maxRequestLength=”10240″/> parameter to a higher value to something higher, such as 15360 (15MB), or larger if you wish..
Save the updated web.config file
Restart IIS (IISRESET)

This forces the server to increase the Maximum Request Length parameter on the web.config file for ActiveSync, thus allowing the iOS devices to stop having that issue.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
WPLGAuthor Commented:
This was a lifesaver.  Thank you!  I actually set it to 25600.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Servers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.