SQL Server not listening on 1433?

EE,

It may be a corrupt server OS but for some reason I can't get these two SQL servers from the same image to respond to 1433 requests via portqry. I turned off the local and domain firewall policy but they still say "not listening" My other SQL servers respond. Besides that, I have gone into SQL Configuration and put 1433 for IPAll (along with the rest) and enabled secure pipes. SQL Server Browser and agent are running.

Any other ideas?
snyderkvAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Brian CroweDatabase AdministratorCommented:
Can you ping/telnet to the SQL instances from your target server?  It may not be SQL related at all.  You could have DNS or IP issues.
Dave BaldwinFixer of ProblemsCommented:
Port 1433 is for TCP/IP connections, has nothing to do with pipes or the other methods.
Kamal KhaleefaInformation Security SpecialistCommented:
Is sql service running
Is there anti virus with network protection
Try to connect to this instance from another server is it connecting ?
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

snyderkvAuthor Commented:
Will check when I'm back in the office but yeah sql is def running. Will also check Anti-Virus exclusions and any vDS settings if anyone has any more input let me know.

Will also try cliconfg.exe to see if that resets thigns
snyderkvAuthor Commented:
Recreated the issue in my lab. I have a named instance and had to remove the default as per STIG. Named instances don't use 1433 default and I'm sure not all applications remoting to this port require it but still trying to enable it for troubleshooting purposes
Dave BaldwinFixer of ProblemsCommented:
Named instances connect thru the 'sqlbrowser.exe' service on port 1434.
snyderkvAuthor Commented:
1434 was still not listening either. Are you saying that's normal? I changed to 1433 for IPAll under SQL Server Configuration and it listens now. Is this a supported config for Named instances? It just doesn't seem normal for named instances to not listen on on either 1433/1434.
Dave BaldwinFixer of ProblemsCommented:
IPAll is for TCP/IP connections.  It has nothing to do with 'named instances' which is handled by the 'sqlbrowser.exe' service on port 1434.  And that is handled by the SQL Native Client driver on the client.  On my computers I can either connect thru an IP address or the named instance.  The IP address connection to the 'sqlsevr.exe' service goes to port 1433 (which I did setup in IPAll) and the named instance connects thru the 'sqlbrowser.exe' service on port 1434.

'named instances' can be used to connect to multiple 'instances' of SQL Server that are installed on a single machine.  A TCP/IP connection can't do that because it only has the machine IP address to connect with.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
snyderkvAuthor Commented:
Dave, not following. Most applicatons on the client that connect to a remote sql server default to or ask for the named instance (or default name) NOT the IP address. Sounds like your talking about when connecting remotely via SQL Management Studio? I'm talking about how applications connect to the back end remotely. If they use 1433 or 1433 for named instances via the browser, then that port should respond from the client i.e SolarWinds connecting to the backend storage via named instance (default during insall). Not sure if it's required to be open in this case but I think it connects via an ODBC connection set to SQL Server Native Client 11.0 (which has 1433 enabled) in SQL configuration manager.
Dave BaldwinFixer of ProblemsCommented:
I have both PHP and ASP programs that connect to my 4 different installs of SQLExpress and I have told you how they are working.  I can switch them between 'named instance' and IP address and they still work.  I even have PHP on Linux connecting to them.

SSMS can connect thru any available protocol.  I normally leave it at 'default' but I don't actually know what that is.  And you can set the SQL Native Client to use any port you want.  The Default for TCP/IP on this computer is 1433.

Info on SQL Browser: https://technet.microsoft.com/en-us/library/ms181087%28v=sql.105%29.aspx
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2008

From novice to tech pro — start learning today.