2008 r2 Primer Domain Controller failed to start

Hi there
Our primer DC failed to start after a power shortage, now every time the machine boot it goes to windows corporation progress bar and then it gives the following message:  
Stop: c00002e3 security accounts manager initialization failed because of the following error:
the security ID structure is invalid
error state : 0x0000078
we don’t have windows backup ,we only have veem backup and unfortunately it gives the same error message
the machine can boot to DSRM , from there I tried to run sfc /scannow and chkdsk ,the system couldn’t find any issues !!

thanks for help
hsenussiAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kamal KhaleefaInformation Security SpecialistCommented:
https://support.microsoft.com/en-us/kb/316751
Before looking to the link is there any error on server
What server brand and model and hdd size ,raid
hsenussiAuthor Commented:
Machine is a Virtual server hosted by esxi 5.5, SCSI controller LSI logic SAS
I’ve checked the provided link , tried to delete SAM,Security,Software and system files from system32\config , and copied the same files from system32\config\RegBack
Still not working ,gives the same error message  0x0000078 , the security ID structure is invalid

thanks king2002
Seth SimmonsSr. Systems AdministratorCommented:
that kb article will do you no good; it is for XP (not 2008 R2) and you are dealing with a domain controller which has its files setup differently because it's part of the active directory database, not local sam files

do you have another domain controller?  i would just seize the fsmo roles on that one and rebuild this failed one.  if your veem backup is not working and you don't have a windows backup, your options are limited
hsenussiAuthor Commented:
The issue  resolved by changing VM (Win DC) server date in BIOS back to the date where the image taken !!! Sounds strange but this this the way that made my DC  boot up normally without any blue screen

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
hsenussiAuthor Commented:
This is the only solution that resolved my issue
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.