RESTFUL webserver

When I run this command http://admin:admin@fibaro.tsc.is/api/devices/4 from Microsoft Edge or wget
I get 400 - Bad Request

When I run the same command from Chrome I get right results.
soffcecManagerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SteHCommented:
does it require authentication? These can be handled differently and depend on the actual configuration of either browser. Most likely wget does not authenticate
0
soffcecManagerAuthor Commented:
curl did the job !
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
soffcecManagerAuthor Commented:
After trying wget and several other command line programs I found out curl.exe was the only program doing it right, but I have no idea why.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
HTTP Protocol

From novice to tech pro — start learning today.