2 TB External USB drive

Intermittently we are unable to see the backup files on the drive.  I can see the folders, just no files.  If we unplug and plug it back in, the files are viewable again.  I have tried turning off power management for the USB ports, but to no avail.
Cyber_JunkieAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kyle GustafsonCommented:
Have you checked Event Viewer for errors with the drive? The system log should show disk related errors, if any.  Also, if you plug the drive into another machine, does it exhibit the same behavior?
BufferstopCommented:
Can you plug it into a different USB plug? can you change the cable?
dbruntonQuid, Me Anxius Sum?  Illegitimi non carborundum.Commented:
How is this drive powered?  Through the USB connection or through an external power supply?  If through the USB connection get an external powered USB hub to connect to the drive and the computer.
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

Michael-BestCommented:
Test the drive with manufactures diagnostic tools.
Download manufactures diagnostic tools from manufactures site or you can find the tools on UBCD
http://www.ultimatebootcd.com/download.html

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nobusCommented:
check also it's energy settings, and set the drive to "NOT save power for this drive"
Cyber_JunkieAuthor Commented:
Sorry for the delay, haven't had an opportunity to go onsite.
nobusCommented:
if the energy settings are the cause -  you only have to wait 10-20 sec to get the drive up to speed
**you can check the settings with rdp - or teamviewer, if you have one such installed
Cyber_JunkieAuthor Commented:
I checked the power savings setting and it was unchecked for the USB drive.
Cyber_JunkieAuthor Commented:
Currently the USB drive is showing as unknown device.  I have tried to reinstall the drivers, remove from the device manager and scan for new hardware, no success.  Comes back as an unknown device
BufferstopCommented:
Can you pug it in to a different pc and see if works?
Cyber_JunkieAuthor Commented:
I can test that next time I am onsite...the problem is that when we unplug and plug back into the server, it works fine for approx. 4-5 days.
Michael-BestCommented:
I suspect what is called "weak contacts" of the USB cable or ports.
Replace the cable, but if it is the ports then replacing the External USB drive case and the last port(s) to suspect is on the mother board.
You can test this out by swapping the External USB drive to another USB port.
Did you test the drive with manufactures diagnostic tools, as I posted before?
nobusCommented:
does the drive have it's own power supply?
if not - use a powered usb hub, like  the top ten shown here :  http://usb-hub-review.toptenreviews.com/
Michael-BestCommented:
@ Cyber_Junkie
Still having the issue?

If a USB powered 2.5" external drive then get a "Y" cable enabling two USB ports to supply power to the external drive.
USB3-y-cable.jpg
Also please read my comments on a similar issue at this link:
http://www.experts-exchange.com/questions/28843379/External-Hard-Drive-unrecognized.html#a41249404
nobusCommented:
i don't favor y ycables for powering usb devices - since they simply connect to the same source
Cyber_JunkieAuthor Commented:
I have replaced the external HD to see if the issue is the USB drive or the OS losing its connection to the USB device.  It has been successful for the last 3 days.  I will continue to monitor for the next week to ensure this issue is resolved.

Thanks to all who contributed.
Michael-BestCommented:
Glad to help.
Cyber_JunkieAuthor Commented:
The new drive has been working for 9 days now with no issues.  I plugged the new drive into the same USB port as the original one.  It looks like the issue was with the drive itself.  I will continue to monitor, however, it looks like the issue was the actual HD and not the OS as I originally suspected.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.