Connection problem to SQL Server 2014 Express

I have installed SQL Server 2014 Express on a new server
I succeeded restoring a database from another SQL Server (2005)
SQL Studio works fine on the server
I adapted the TCP port on all IP addressed to 1433
Now I try to connect from a PC in the same network (TCP/IP) but it fails
Even running an local application that connects to the SQL server with TCP/IP fails
What shell I verify/set for TCP ?
(during the test, I disabled the server firewall to be sure)
LVL 1
LeTayAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Barry CunneyCommented:
Hi LeTay,
Please post up any message that is returned when you try to connect from a PC.
0
Éric MoreauSenior .Net ConsultantCommented:
you need to open the SQL Configuration app and enabled TCP/IP protocol
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LeTayAuthor Commented:
tcp/ip is enabled on all IP adresses
Does it need to be enabled somewhere else ?

For example, error trying to connect from for example from Studio from another PC
(french version)
Une erreur s'est produite lors de l'établissement d'une connexion au serveur. Lors de la connexion à SQL Server , cet échec peut être dû au fait que les paramètres par défaut de SQL Server n'autorisent pas les connexions à distance. (provider: Interfaces réseau SQL, error: 26 - Erreur lors de la localisation du serveur/de l'instance spécifiés) (.Net SqlClient Data Provider)
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

kaskhedikar_tusharCommented:
Hello,

First of all, check the port has opened from firewall.
Use telnet to check this.

Then go to SQL server configuration, enable TCP/IP Name Pipe protocols.
Make sure that SQL browser service should be running.

Hopefully this steps will be work for you.


Regards,
Tushar Kaskhedikar
0
Éric MoreauSenior .Net ConsultantCommented:
Try using the ip address in your connection string instead of the server name
0
Vikas GargBusiness Intelligence DeveloperCommented:
Hi,

Please check that "Allow remote connections to this server"
Property has been checked in.

it is in the properties tab of sql instance - Connections tab.
0
LeTayAuthor Commented:
1. Firewall is currently disabled
2. Remote connection is enabled (server properties seen with Studio)
3. In the configuration, looking at Protocols for SQLExpress, TCP/IP is Enabled
4. In the same config of TCP/IP, all IP Addresses are active, enabled = yes, tcp dynamic ports empty and TCP PORT = 1433
5. Looking with Process Explorer the SQLServer process TCP/IP stuff, i see :
    Protocol TCP Local Address serverfullname:ms-sql-s LISTENING
    Protocol TCPV6 Local Address serverfullname:1433 LISTENING
6. Trying to connect with IP addresse fails
What else should I check ?
0
LeTayAuthor Commented:
I have tested the connection with telnet and that one connects correctly (telnet servername 1433)
So ?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.