Default Document Mode in IE 11

Hello,

I'm having an issue with the Document Mode in IE11. For some reason some of my systems are defaulting to 7 when I need them to be edge by default. This is strange since I use GP to maintain settings globally on my domain as well as create my loads from our windows Deployment Services server (I would expect setting to be uniform across the domain.)

If I try to manually change it via the developers tool (F12) to edge, it errors and crashes IE. I can't seem to hunt down a GP setting or Reg hack to fix this problem, and I don't understand where this setting is coming from. It's not in my GP's and I don't have it set manually in Compatibility View. It's not scripted on the website itself, and my machines are showing different modes on the same sight.

Any Ideas? Thanks for any Help
Eric
bwaskAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MereteCommented:
According to this>How to set IE11 Document mode to edge as default?
The rendering mode in Internet Explorer 11 can appear stuck if the site is added to your local Compatibility View list. When this happens, the rendering mode inside the developer tools and out will default to the specified compatibility settings.
0
bwaskAuthor Commented:
Yes, as I said above "I don't have it set manually in Compatibility View" so I really am confused as to where this setting is coming from.
0
MereteCommented:
my machines are showing different modes on the same sight. You may have to manually check  these machines.
Forgive me but I can only go by your details.
Did you read the full suggestions? At the bottom is several options,
resetting IE
http://support.microsoft.com/kb/923737
uncheck the "Automatically detect settings" in the Local Area Network Settings (found in "Internet Options" > Connections > LAN Settings.
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

bwaskAuthor Commented:
Resetting all IE config setting is great, and did indeed fix it, (at least until I rebooted.) However, what it did tell me was my problem had to be something in my Group Policy configureation.

Here is what I found:

For whatever reason, Internet Explorer likes to hang on to the "display intranet sites in compatibility view" setting under "Compatibility view settings" for the internet as well, in a rather random fashion.

I didn't have a group policy defining it so what I did was configured:

Computer Configuration/Administrative Templates/Windows Components/Internet Explorer/Compatibility View/Turn on Internet Explorer Standards Mode for Local Intranet

To be enabled. Which forces the "Display intranet
sites in Compatibility view" to be unchecked in Compatibility View Settings, which in turns forces IE to run in the most current document mode (in my case that would be Edge.) I'm still not sure why my workstations were just kind of randomly picking a doc mode, but now that they are forced to a particular type my problem seems to have disappeared.


Thanks for the help
Eric
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bwaskAuthor Commented:
I selected my solution because it actually fixed the problem, Merete's s got me on the right track though.
0
MereteCommented:
Thankyou Erik glad it helped you.
regards Merete
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.