Issue with OWA in 2013/2010 Co-Existence Environment

Hi Experts -

I am troubleshooting a strange issue, and can't seem to resolve it.

We are currently in the middle of an Exchange migration project from 2010 to 2013. Everything has been relatively smooth until now.

Our 2013 OWA server allows users to log in, both internally and externally without issue. If the user's mailbox is already migrated to Exchange 2013, they have no issue. If the user has a 2010 mailbox, they are able to log in, get redirected to the proper 2010 OWA server and put into their mailbox. However, as soon as they make any action at all, they are kicked back to the 2013 OWA login page. This issue is not happening to ALL 2010 users, but it is definitely happening to the majority of them. I can't seem to find anything in the logs that points to what is causing the issue.

Some answers to possible questions for clarity:

- This issue occurs whether a user is connecting to OWA internally, or externally.
- This issue occurs whether a user connects via https://webmail.domainname.com/owa or directly to https://exchange2013serverhostname.domain.local/owa
- This issue does NOT occur if a 2010 mailbox user connects to https://exchange2010serverhostname.domain.local/owa
- This issue does not happen to 100% of 2010 mailbox users, but does happen to most of them.
- This issue does not happen if I create a brand new 2010 mailbox, and connect to OWA 2013, and get redirected to the 2010 version to get into their mailbox
- In the event that I migrated an affected user's mailbox to 2013, the issue goes away. However, we are not prepared to fully migrate everyone right now, so this isn't a viable option.

I'm thinking it might be an IIS issue, but on all Exchange OWA servers, the authentication settings are the same, and if a 2010 users logs into 2010 OWA directly, everything works fine. If a 2013 user logs into 2013 OWA directly, everything works fine. It's just when a 2010 user logs into the 2013 OWA login page, then gets redirected to their mailbox on 2010 (which is intended), when they click on ANY item at all within the page, they get kicked back to the 2013 OWA login page again.

Thanks in advance.
Veritas781Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

The_KirschiCommented:
Hi, this sounds really strange. What happens if the user logs in again after being redirected from OWA 2010? Did you check this?
Veritas781Author Commented:
Hi The_Kirschi, thanks for the reply. When they log back in again, the cycle repeats. They get put into their mailbox, but as soon as they click anything at all, they get put back to the 2013 OWA sign in page again.
The_KirschiCommented:
Is there any chance that this is a browser issue? As you say only some users have this problem, do they use a different version of the same browser as others or a different browser?
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Veritas781Author Commented:
Unfortunately, this happens on all browsers, and on multiple machines.

One thing to add, if a user is having this issue, I can use their PC and the same browser with an account that is not having this issue (such as a freshly created account), and everything works perfectly fine.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Veritas781Author Commented:
More information that may be relevant:

User A is on MXDB1 (Exch2010) and has this issue
User B is on MXDB2 (Exch2010) and does NOT have the issue

After migrating User A to MXDB2, he STILL has the issue.

This somehow has to be related to the user account, but I ran a Get-Mailbox -Identity "username" | fl and exported to a file, then compared them line by line, and everything is completely identical (except for the names of the accounts, of course).
The_KirschiCommented:
May I ask a question:

Wouldn't it be sensible to get rid of the problem by moving those mailboxes to 2013? I mean this is what you are trying to accomplish in the end and it would probably save you the time you waste for solving this problem.
Veritas781Author Commented:
That is the ultimate goal, of course. However, we have a complicated Blackberry Enterprise deployment in our environment, and that would require fully building and testing a new BES server, since a single BES server can only point to one Exchange environment at a time. My focus is shifting towards that end, since if I can accomplish that, I can begin to migrate all mailboxes to alleviate this issue. Although, I would still like to get this issue resolved.
The_KirschiCommented:
I understand. Too bad.

Can you try to connect to this URL with one of the affected accounts and see if this changes anything?
https://"your owa url"/owa/?layout=light
Veritas781Author Commented:
We ended up completely recreating the virtual directories. That fixed it.
The_KirschiCommented:
Ok, glad you got it solved.
Veritas781Author Commented:
Resolved issue with Microsoft support.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.