Link to home
Start Free TrialLog in
Avatar of Zolf
ZolfFlag for United Arab Emirates

asked on

Cannot view user in the Security section of the database

Hello there,

I have a user zaj to whom i have given db_owner permission to a database but for some reason the user is not displaying in the database's security section. what could be the reason.

cheers
Zolf
Avatar of Brian Crowe
Brian Crowe
Flag of United States of America image

How did you give him db_owner permission then?  There is a difference between an instance LOGIN and a database USER.  Are you sure you don't have the former and are missing the latter?
Avatar of Zolf

ASKER

Forgot to attach screenshot. this zaj I have given him sysadmin permission

User generated image
Hi,

Select the user to which you want to get displayed at your database.

go to properties - > User Mapping - > uncheck the database and check again

Check the DB_owner and click OK.

Your user should be displayed in the user column of the database where dbo is shown currently.
Avatar of Zolf

ASKER

Thanks for your feedbacks.
One thing, this user zaj is sysadmin,could be that sysadmin user is not shown in the database's - security - user folder???
the reason is when i create a new user and add map them to a db, they are added but not this user.
Also when you see that screenshot, in the user column it shows dbo instead of zaj,why??
Did you Refresh the Security folder after giving him db_owner rights?
Also, check the login for the dbo. He might be him already.
Avatar of Zolf

ASKER

yes i did, and i still cannot get this user in that security folder
Avatar of Zolf

ASKER

Brian,

Can you please elaborate more on this in few words or refer some good article

There is a difference between an instance LOGIN and a database USER.Are you sure you don't have the former and are missing the latter?
Avatar of Zolf

ASKER

I've requested that this question be deleted for the following reason:

no help
ASKER CERTIFIED SOLUTION
Avatar of Brian Crowe
Brian Crowe
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of Zolf

ASKER

Brian, thanks very much for your feedbacks. cheers!!