Connection string for SQLOLEDB connection to SQL Server 2012

Currently my Delphi application connects to a SQL Server 2005 (ADO component)
The connection string that works is this one :
"Provider=SQLOLEDB.1;Data Source=TheSQLServerName;Initial Catalog=gmProduct;User ID=gmProduct;Password=xxxx;Auto Translate=True"
Now I have installed SQL Server Express 2014 on another machine
Trying that connection string fails
Do I have to specify something else in the string ?
I already tried (same error) Data Source=TheSQLServerName\SQLEXPRESS
LVL 1
LeTayAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

LeTayAuthor Commented:
More info ...
The error trying to connect is
Cannot open database ... requested by the login. The login failed
I verified the UserName and Password, they are correct...
So ?
0
ThommyCommented:
Are you running your Delphi application on the same machine where SQL Server Express 2014 is installed or are you trying to connect from a Client pc?
0
Sinisa VukSoftware architectCommented:
Think you need to use SQL Server Native Client 11.0 OLE DB Provider. Here are some connection strings.
something like:
Provider=SQLNCLI11;Server=myServerAddress;Database=myDataBase;Uid=myUsername;
Pwd=myPassword;

Open in new window

Go through older EE qustion too....
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

LeTayAuthor Commented:
Running from another machine in the network
From that machine, ISQL and Studio can connect correctly with same user and password
0
Mr KnackeredCommented:
Make sure the SQL Browser service is started and you have enabled the protocol for connectivity ie TCP or which ever being used is enabled in SQL and that required ports for access are allowed through the firewall ie port 1433 for TCP.

If using SharedMemory connection on the same machine as SQL then just enabling the SQL Browser service may sort it out.
0
ThommyCommented:
SQL Server Express has Network connectivity disabled by Default.

You have to enable it in SQLServer Configuration Manager

How to configure TCP/IP access for SQL Server/Express 2014
0
LeTayAuthor Commented:
With the connection string, as I mention above, the connection is established but it says :
Cannot open database  .... requested by the login. The login failed

I can try the SQLNCLI11 but I guess that I need to install it on ALL PCs that runs the application ?
0
LeTayAuthor Commented:
I found the error : mine !
I wrongly typed the database name !
It works now
I dont' know how to close this question now (about the points)
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Geert GOracle dbaCommented:
your answer was correct, so accepting your answer is accepted
0
LeTayAuthor Commented:
I found my mistake : error in the server name !
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.