SQL Job Output to Cloud Share

First of all, pardon my lack of knowledge of cloud terminology and how it all works.

SQL Server 2008 r2.

We have a job where we specified the output (under Edit Step, Advanced - see attachment) to a share on another server.  Recently, that server has been moved to the cloud (our network admin calls it NAS).  Even though we entered the URL to that share on the cloud, the file is not created there, but the job does not fail.

Is there a problem writing to the cloud via the SQL job output?  Why? Is there a solution?

Any help or direction would be greatly appreciated.

Peg
Margaret DullnigAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rich WeisslerProfessional Troublemaker^h^h^h^h^hshooterCommented:
The most common reason that would fail is the credentials running the job don't have permission to the NAS volume...
0
Margaret DullnigAuthor Commented:
That is the first assumption we made.

According to my network admin, the same permissions have been applied to the NAS as to the old server.

Thanks.
0
Rich WeisslerProfessional Troublemaker^h^h^h^h^hshooterCommented:
If it were me, I'd attempt to confirm by either logging into the console with the same credentials used by the job, or starting a specific process with those credentials (shift-right click, run as different user) and confirm that you can access the NAS URL.  That has the advantage that, if the problem is related to access, and it isn't permissions, you might get a specific error back which will indicate what the problem is.
1
The Firewall Audit Checklist

Preparing for a firewall audit today is almost impossible.
AlgoSec, together with some of the largest global organizations and auditors, has created a checklist to follow when preparing for your firewall audit. Simplify risk mitigation while staying compliant all of the time!

Margaret DullnigAuthor Commented:
I guess I really didn't give enough info in my original post.  The network admin did log onto the SQL Server server with the same credentials and was able to map a drive to the NAS share and create a file there.  I also created a test job to write its output to a different cloud share to test if the output feature worked with another NAS share.  It did not.
0
Margaret DullnigAuthor Commented:
Thank you Rick for your responses.

 My network admin decided to try pulling the credential out of the permissions group and applying it by itself.  That seemed to solve the problem, although we don't know why.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Rich WeisslerProfessional Troublemaker^h^h^h^h^hshooterCommented:
Excellent.  The good (and bad) news is that I would have expected it to work.  If you were writing to a network share before, I would expect a NAS volume to work similarly.  That means, given that it isn't working... it's an assumption or something in a specific implementations.  Just to eliminate some of the assumptions:

I assume when you say you are specifying a URL for the output... it something of the form of \\NASName\Volume\directories  ... and that's the same as the URL used to map the drive.  (pretty standard, but wanted to confirm.)

I assume none of the URLs are using DFS (Distributed File System), etc.  (I can't think of any reason DFS wouldn't work, but I'm not even looking in that directly, because I assume nothing of the sort is in use.)

With the test job writing to a different output device... did you happen to use your own credentials or still using the same credentials as the old job?

Can you check with the network admin to see if there are any errors on the NAS device?  (Protocol errors, or authentication errors especially...)

Can you say what NAS device is being used?  
Do you know what authentication to the NAS device is being used?   (I.e. NTLM, kerberos, etc)
0
Rich WeisslerProfessional Troublemaker^h^h^h^h^hshooterCommented:
" My network admin decided to try pulling the credential out of the permissions group and applying it by itself.  That seemed to solve the problem, although we don't know why"

Ah.  *scratches.head*  Okay... In windows, the authentication token is built at when you connect.  Adding a new group won't grant any new rights until the token is rebuilt.  Normally, I would expect completely disconnecting the user from the NAS box and reconnecting would cause the token to be recreated.  I guess in your specific case it wasn't (or something was maintaining a connection using those credentials.)
1
Margaret DullnigAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for PegJHU's comment #a41135525

for the following reason:

Rick stayed engaged to help me find a solution.  My network admin continued to work the problem and found the solution.
0
Rich WeisslerProfessional Troublemaker^h^h^h^h^hshooterCommented:
May I please request the assist on the answer, since we were on the track of credentials from the start?
0
Margaret DullnigAuthor Commented:
Yes Rick, how do I do that?
0
Rich WeisslerProfessional Troublemaker^h^h^h^h^hshooterCommented:
There's an embarrassing question as I haven't asked a question in quite a while, I hope the interface hasn't changed too much.  From the support site:
If there are several comments that served as your answer, you can choose to divide points between accepted and assisted solutions. Click the black check plus icon in the upper right-hand corner of the comment that best solved the problem. On the next page, you will see each of the comments from your question; tick the checkbox on the left side of each comment you would like to include as an assisted solution. You may then assign point values accordingly for each comment in the box to the right. Tap the overall grade for your solution (excellent, good or average) and add any additional comments, then tap “Submit.”
Marking your own answer as one of the answers will still put the question in a multi-day waiting period for comment and review... but at the end of that period, if the moderators don't take action, the question will close.
0
Margaret DullnigAuthor Commented:
Rick stayed engaged to help me find a solution.  My network admin continued to work the problem and found the solution.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.