Secondary email address is undeliverable (secondary domain)

I'm probably missing something stupid and simple. But as a 1-man IT department, I don't have a second set of eyes to pick up on my mistake...

A sister company closed its US office and some of the employees moved to our office. Their managed service provider shut down their Exchange server, but assigned ownership of the domain name to us. I duplicated the DNS Zone File information for the second domain name on the GoDaddy web portal to match our primary domain. On my Exchange 2010 server, I added an additional email address to select users such as name@seconddomain.com.

However, when I send a test email from an outside source, I keep getting "Delivery Notification: Delivery has failed" messages:

This report relates to a message you sent with the following header fields:

  Message-id: <ca379176-6b71-482c-92e3-025c360fb2c5@me.com>
  Date: Wed, 28 Oct 2015 14:00:15 +0000 (GMT)
  From: Eric Jack <eajack@blah.com>
  To: ejack@seconddomain.com
  Subject: Test 10:00

Your message cannot be delivered to the following recipients:

  Recipient address: ejack@seconddomain.com
  Reason: Remote SMTP server has rejected address
  Diagnostic code: smtp;550 5.7.1 Unable to relay
  Remote system: dns;mail.mycompany.com (TCP|17.172.109.150|44229|(My IP)|25) (mail.mycomany.com Microsoft ESMTP MAIL Service ready at Wed, 28 Oct 2015 10:00:29 -0400)
Eric JackIT ManagerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Todd WedlakeSystems AdministratorCommented:
the mx record (with your hosting provider's DNS) for the shutdown exchange environment must be configured to route email to your existing exchange server.

so if your working mx record is mail.domain1.com and all email is working there

then your mx record for old domain should also be mail.domain1.com

you also have to set your receive connector within exchange to accept email for old.domain.com
0
Eric JackIT ManagerAuthor Commented:
Well, that's why I'm still perplexed. I've configured the DNS settings for the secondary domain on GoDaddy to match that of our primary domain. See the screenshots I've attached.

Here's the DNS settings for the company's primary domain:
Primary domain DNS settings on GoDaddyAnd here they are for the secondary domain I'm trying to get emails for:
Secondary domain DNS settings on GoDaddy
Regarding the Receive Connector on the Exchange server, I have one in place for mail.comarktv.com. Since the DNS settings on GoDaddy have linear-tv.com email going to mail.comarktv.com, what do I need to add in Exchange?

If I try to create a new Receive Connector, I'm getting this error:

Summary: 1 item(s). 0 succeeded, 1 failed.
Elapsed time: 00:00:00


Linear Forwarding
Failed

Error:
The values that you specified for the Bindings and RemoteIPRanges parameters conflict with the settings on Receive connector "SWIK-S-EX01\Default SWIK-S-EX01". A Receive connector must have a unique combination of a local IP address, port bindings, and remote IP address ranges. Change at least one of these values.
Click here for help... http://technet.microsoft.com/en-US/library/ms.exch.err.default(EXCHG.141).aspx?v=14.1.218.11&t=exchgf1&e=ms.exch.err.Ex142B4F

Exchange Management Shell command attempted:
new-ReceiveConnector -Name 'Linear Forwarding' -Usage 'Custom' -Bindings '0.0.0.0:25' -Fqdn 'mail.comarktv.com' -RemoteIPRanges '0.0.0.0-255.255.255.255' -Server 'SWIK-S-EX01'

Elapsed Time: 00:00:00
0
Todd WedlakeSystems AdministratorCommented:
shouldn't that be

New-ReceiveConnector -Name 'Linear Forwarding' -Usage 'Custom' -Bindings '0.0.0.0:25' -Fqdn 'decommissioned domain.com' -RemoteIPRanges '0.0.0.0-255.255.255.255' -Server 'SWIK-S-EX01'
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

Todd WedlakeSystems AdministratorCommented:
and create an MX record for the decommissioned domain (wherever that domain is being hosted) that points to the IP address of 173.13.119.72
0
Eric JackIT ManagerAuthor Commented:
The decommissioned domain is hosted by GoDaddy, same as the active domain. As you can see in my screen captures above, the DNS settings for linear-tv (the decommissioned domain) have the following settings:

A (Host) Mail = 172.13.119.72
MX host @ points to mail.comarktv.com

Should the MX record on linear-tv.com instead say mail.linear-tv.com and then create a new Connector on the Exchange server with the FQDN mail.linear-tv.com?

I thought by "redirecting" the decommissioned domain name in the DNS settings on GoDaddy's site, it would redirect emails. Apparently since the email address is still xxx@linear-tv.com that wasn't working.
0
Todd WedlakeSystems AdministratorCommented:
ok your dns is fine.  need to tell exchange now to accept email for linear-tv.com via a receive connector.
0
Eric JackIT ManagerAuthor Commented:
Okay, but I'm having trouble with that. From the Exchange Management Console > Server Configuration > Hub Transport > New Receive Connector...

In the "wizard", I'm giving it a Name: Linear Forwarding, Intended use: Custom, Local network settings: Leaving all available IPv4, Specify FQDN mail.linear-tv.com, Remote network settings, IP addesses: leaving all, but then getting the same failure I mentioned above.
0
Todd WedlakeSystems AdministratorCommented:
my bad.. I didn't catch that you were using the same internal IP address for this new receive connector as you are with the old receive connector.

You must have different internal IP addresses for each receive connector.

you need to make sure your firewall is allowing that through as well.

receive connector 1 (existing that works) should be for example 192.168.1.10:25 and allowed through the firewall

receive connector 2 (new one) should be for example 192.168.1.11:25 and allowed through the firewall.
0
Eric JackIT ManagerAuthor Commented:
Different IP addresses?! So if I have multiple domains, I would need a different IP address for each? (Internal or external?)

A few years ago when we changed our company name, we had kept the old domain name email address on everyone's mailbox, but just created a new domain name email address and made it the primary address. I don't remember having to have different connectors or IP addresses. We just had our domain host point each domain to the mail server and things worked.
0
Eric JackIT ManagerAuthor Commented:
Ah, figured it out! We were barking up the wrong tree. Seems all that was needed was to add another entry in the "Accepted Domains".

Exchange Management Console > Organization Configuration > Hub Transport > Accepted Domains > New Accepted Domain. Just give it a name and the domain. In my case: Linear, linear-tv.com.

Once I applied that, I sent a test email to my test@linear-tv.com address from an outside source, and it came right through! In fact, the entry was still there for the old company name domain we no longer use.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Eric JackIT ManagerAuthor Commented:
I discovered the correct answer on my own and posted it to help anyone else who runs into this problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.