Changing MX Record of the Domain Name so that it point to my Email Server

DNS Zone File of the DomainA RecordCName and MX RecordHi,

  I used to have Godaddy to host my website and email for my domain name - THE*****INC.COM.
  Since I have my own webserver, I learned that I could have A record (please see the screenshot) point to my static IP address of 64.xxx.xxx.242. My CISCO router (64.xxx.xxx.242) then forwards port 80 to my internal web server (192.168.1.x) where I am running IIS.

  I like to know if I can do the same for email. I have an exchange server that has public static IP address ( 64.xxx.xxx.243). This exchange server (virtual machine in my VMware box) is NOT on the private network (192.x.x.x). It is directly connected to ISP internet modem.

  That said, is it possible to modify CNAME and MX Record in my Godaddy account to send email traffic to my exchange server?
LVL 1
sgleeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

junyapCommented:
Hi sglee,

Yes, by default GoDaddy has entries like CNAME and MX in your DNS Panel.

Thanks,
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Hypercat (Deb)Commented:
Here's what you need to do:

First, add an A (Host) record for your mail server.  The host name would be SMTP, or MAIL or whatever you want to use, and the IP address would be the public IP address of the Exchange server.

Then, delete the MX records that are there and add a single MX record pointing to the host record that you just created as the single email server.
0
sgleeAuthor Commented:
@hypercat,

  "First, add an A (Host) record for your mail server.  " --->  I just added A record and pointed it to 64.xxx.xxx.243. Did I do it correctly?
A record revised
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

Hypercat (Deb)Commented:
No - the host name CANNOT be @ because the @ sign must point to the IP address of your Godaddy server. Rather it has to be a specific server name for your Exchange server itself - i.e., whatever you want to call your Exchange server specifically. It can be the same name you use internally for your Exchange server, or it can be something generic like "mail" or "SMTP."  So, for example, if you want to call your mail server "MAIL" and the public IP address of your Internet connection that the Exchange server uses is x.x.x.x, then the host record would be:

Host name: Mail
IP address: x.x.x.x
0
sgleeAuthor Commented:
Full Computer NameA Record
When I type in HOSTNAME in command window, it returns "CGI1".

Did I do it right?
0
Hypercat (Deb)Commented:
Sure, that's fine.  Now, you need to go to the MX section, remove the older MX records, and create a new MX record and under the "points to" you would put cgi.yourdomain.com.  The "yourdomain.com" part would be your PUBLIC domain name, not the CGI.LOCAL which I assume is your internal domain name.
0
sgleeAuthor Commented:
MX record revisedDid I do it right?
0
sgleeAuthor Commented:
Recipient PoliciesDomain User - Default Email AddressRight now, I can send email out from my exchange server (CGI1.CGI.local server). When I receive that email, I see that the sender is frank***@THE*****INC.COM.
(1) However when I reply to that email or try to send a new email to frank@THE*****INC.COM, it fails.

(2) When I ping my exchange server name, it returns correct IP adddress like below:
C:\WINDOWS\system32>ping cgi1.THE*****INC.COM.com
Pinging cgi1.THE*****INC.COM [64.xxx.xxx.243] with 32 bytes of data:
Reply from 64.xxx.xxx.243: bytes=32 time=27ms TTL=120
Reply from 64.xxx.xxx.243: bytes=32 time=21ms TTL=120

(3) However when I ping
C:\WINDOWS\system32>ping mail.THE*****INC.COM.com
Ping request could not find host mail.THE*****INC.COM.com. Please check the name and try again.

Obviously I am missing something here.
Should I have named the server "mail.PublicDomain.com" instead of "CGI1.CGI.local" or that does not matter?
0
Hypercat (Deb)Commented:
Yes, you need to name the server on GoDaddy DNS settings with your external domain name, not the internal one.  I thought I had said that, but maybe I wasn't clear. I think I mistyped something on a previous post - the GoDaddy A record is named "Mail" and the MX record has to point to mail.yourexternaldomain.com.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.