SYSVOL replication issues

Someone tried to apply a new group policy this morning for IE intranet/security zones and now IE wont save sites in the trusted sites. After investigating I am finding that GP are not being replicated across all four of our domains correctly. GPOTOOL is showing sysvol mismatch and error 2, where one policy doesn't exist on one server but exists on the other three.

Safe to say I am sure all four domain controllers dont have the correct SYSVOL. I get mixed results when reviewing \\server.local\policies on different machines. How can I go about rebuilding all of it? Three of the domain controllers are 2008 one is 2003.
LVL 2
stlhostAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Radhakrishnan RSenior Technical LeadCommented:
Hi,

Which replication method you are using? dfs or ntfrs?. Since you have a 2003 DC as well in the network, I believe you might be using NTFRS? If so, you can go for the general Burflag procedure.

But, how you will find out which server has got good copy of sysvol? since you have 2003 DC then the process may be easier for you. You can open "replmon" onto the 2003 DC and add the other DC's as well and compare the version.

Also, check the event logs (File replication logs) for replication errros, if any of the server doesn't have errors, probably that server will be having good copy. If you found such servers then goahead with Burflag.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
stlhostAuthor Commented:
NTFRS. I did try the D2/D4 registry trick but it didnt help.

Event logs
The File Replication Service is having trouble enabling replication from DC2 to DC1 for c:\windows\sysvol\domain using the DNS name DC2.server.local. FRS will keep retrying.
 Following are some of the reasons you would see this warning.
 
 [1] FRS can not correctly resolve the DNS name DC2.ctitle.local from this computer.
 [2] FRS is not running on DC2.ctitle.local.
 [3] The topology information in the Active Directory Domain Services for this replica has not yet replicated to all the Domain Controllers.
 
 This event log message will appear once per connection, After the problem is fixed you will see another event log message indicating that the connection has been established.


1) I can resolve DC1 and 2 just fine
2) NTFRS is running
stlhostAuthor Commented:
At this point how do I blow it all away and just start over? I'm not sure which one even has the correct
stlhostAuthor Commented:
hmm, oddly worked itself out. Maybe the burflag did work. I will go ahead and accept your answer
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.