Latency Issues with Mac's on new Cisco Switches

Hi everyone,

We have gone through a refresh of all of our networking equipment. It was old 3COM switches that were end of life. Ever since we replaced the equipment our graphics department has been complaining of slowness/unresponsiveness across the network to their fileserver.

To help mitigate issues, i migrated all workstations onto the same switch (to eliminate multiple hops).

My question to everyone, is there specific protocols that Mac equipment need to function through a Cisco switched network that differs than a Windows network? All windows machines on the same switch do not report any issues.
is_staffAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

strungCommented:
Make sure spanning tree protocol is turned off on your switches if that is an option. Macs don't seem to like spanning tree protocol.

https://discussions.apple.com/thread/3917712?tstart=0
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
is_staffAuthor Commented:
Hi thanks for the quick response...

So it does appear our switches have spanning-tree enabled. Not sure if we can disable it though as it would have to effect entire VLANs vs particular ports.

Is it possible to block STP on just those ports?
0
JustInCaseCommented:
Is it possible to block STP on just those ports?
It is possible , and also recommended for edge ports (connected to end devices) to be configured with
# interface fa 0/0
# spanning-tree portfast bpdu-guard

to configure multiple ports at once you can configure with
# interface range fa0/0 - 4, fa0/17
# spanning-tree portfast bpdu-guard
(this would select ports 0, 1, 2, 3, 4 & 17)
0
serialbandCommented:
Bonjour floods the network with broadcast packets and turning that off might make it work a little better

Taken from https://apple.stackexchange.com/questions/151485/how-do-i-disable-bonjour-visibility-after-yosemite-install

and http://blog.spikie.info/osx-10-10-yosemite-how-to-disable-bonjour-service-advertising-without-disabling-dns/



In OS X 10.9, Bonjour advertising can be disabled by following the steps listed at "How to disable Bonjour service advertising":

        Make a back up copy of the mDNSResponder.plist file as a precaution. Open the mDNSResponder.plist file in Terminal using your preferred text editor. Here is a sample command:

        sudo nano "/System/Library/LaunchDaemons/com.apple.mDNSResponder.plist"

        Add "-NoMulticastAdvertisements" to the array in the "ProgramArguments" section.

Example:

<key>ProgramArguments</key>
<array>
    <string>/usr/sbin/mDNSResponder</string>
    <string>-launchd</string>
</array>`

becomes...

<key>ProgramArguments</key>
<array>
    <string>/usr/sbin/mDNSResponder</string>
    <string>-launchd</string>
    <string>-NoMulticastAdvertisements</string>
</array>

        Save the file.

        Important: If you edited this file using emacs, you must remove the emacs backup file (the file with a tilde at the end of the name, "/System/Library/LaunchDaemons/com.apple.mDNSResponder.plist~") or your Mac will not start up.

        Restart your Mac.


If you have Yosemite
2
down vote
accepted
      

There is no more com.apple.mDNSResponder.plist in OS X 10.10. The service that controls mDNSResponder is now discoverd. The plist file you are looking for is actually:

/System/Library/LaunchDaemons/com.apple.discoveryd.plist

You want to add --no-multicast to the ProgramArguments in that file.

    <key>ProgramArguments</key>
    <array>
            <string>/usr/libexec/discoveryd</string>
            <string>--udsocket</string>
            <string>standard</string>
            <string>--loglevel</string>
            <string>Basic</string>
            <string>--logclass</string>
            <string>Everything</string>
            <string>--logto</string>
            <string>asl</string>
    </array>

Becomes

    <key>ProgramArguments</key>
    <array>
            <string>/usr/libexec/discoveryd</string>
            <string>--udsocket</string>
            <string>standard</string>
            <string>--loglevel</string>
            <string>Basic</string>
            <string>--logclass</string>
            <string>Everything</string>
            <string>--logto</string>
            <string>asl</string>
            <string>--no-multicast</string>
    </array>

You'll want to be very careful when editing that file. You can also use this script to do it for you - https://raw.githubusercontent.com/MacMiniVault/Mac-Scripts/master/disablebonjour/disablebonjour.sh
0
is_staffAuthor Commented:
Appears to have resolved some issues.


Currently fighting local Mac server issues.


Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apple Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.