Configuring ASA5505 for internet access

Limited knowledge on Cisco. Bought this Cisco ASA5505 to add security to inside network an also switch ISP provider to a faster one.

Information:
Modem/ Router set up in bridge mode - DONE
office IP provided by ISP 70.XX.XX.250, 255.255.255.252
Gateway 70.XX.XX.249
DNS 24.55.102.2, 24.138.252.19

ASA Configuration
IP 10.10.10.1 for DHCP range 10.10.10.10 to 10.10.10.132

ASA Version 8.3, ASDM 6.4

Problem:
Now the problem is if I go an change via ASDM to static IP on the outside interface I loose connectivity to the internet.

Current Configuration
:
ASA Version 8.3(1)
!
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp setroute
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
object network obj_any
 subnet 0.0.0.0 0.0.0.0
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
!
object network obj_any
 nat (inside,outside) dynamic interface
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 10.10.10.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 10.10.10.5-10.10.10.132 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:29d6b2956c3aaffb97010e7061a8cf4b
: end
no asdm history enable

Need assistance on this cause I need to use that Static IP in order to create a VPN connection to other office.
AcostaJAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ncomperCommented:
When set as DHCP can you confirm what IP address the unit is given? i wonder is its as simple as the ISP has not setup a static IP address for you.
Dan CraciunIT ConsultantCommented:
After changing the IP you also need to add a default route. It won't work otherwise.

HTH,
Dan
ncomperCommented:
Dan, i didnt think i spotted a default route..... but thought i was just being special
Become a Leader in Data Analytics

Gain the power to turn raw data into better business decisions and outcomes in your industry. Transform your career future by earning your MS in Data Analytics. WGU’s MSDA program curriculum features IT certifications from Oracle and SAS.  

AcostaJAuthor Commented:
Hi,

ncomper - the ISP set at all, I test it with a pc connect it to the modem router (Arris TG862 in bridge) directly in bridge a set  my static IP gateway an dns to the computer an work.


Dan Craciun - can you provided me with an example of the route?
AcostaJAuthor Commented:
I add:
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 70.45.X.X 255.255.255.252
!
ftp mode passive
object-group network obj_any
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
nat (outside) 0 10.10.10.0 255.255.255.0
route outside 0.0.0.0 0.0.0.0 70.45.X.X 1

but still no internet connection, more help?
Dan CraciunIT ConsultantCommented:
In ASDM you need to configure:
1. Interfaces -> outside
2. Routing -> Static routes -> outside
ncomperCommented:
route outside 0.0.0.0 0.0.0.0 70.45.X.X 1

office IP provided by ISP 70.XX.XX.250, 255.255.255.252
Gateway 70.XX.XX.249
DNS 24.55.102.2, 24.138.252.19

First thing you need to confirm that ICMP is permitted (icmp permit any outside )
you need to route via the Gateway 70.X.X.249, or you can confirm by completing a tracert from your client PC to google and confimr the IP that is the next hop after the Cisco (when set as DHCP)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AcostaJAuthor Commented:
Just to let you guys now that it is resolve, a simple restart did the trick, after change some configuration with the route. Thanks
Pete LongTechnical ConsultantCommented:
AcostaJ - When you get five mins can you close the question out m8 :)

Please DON'T accept this comment

Pete
AcostaJAuthor Commented:
Solution:

route outside 0.0.0.0 0.0.0.0 LIBERTYGW 1
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.