dfs can't enable 2008 mode

Implemented a new 2012 file server and want to enable DFS.  Problem is when I go to create a namespace the 2008 mode check box is grayed out.  The domain level is set to 2008 r2 and all the domain controllers have been rebooted as well as the file server but still can't check the box.  Any ideas?
lsysamcAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rich WeisslerProfessional Troublemaker^h^h^h^h^hshooterCommented:
Where do you have the DFS Namespace Service installed, and have you confirmed that the service is running?
0
lsysamcAuthor Commented:
IT's installed on the new 2012 R2 server and the service is running.
0
Rich WeisslerProfessional Troublemaker^h^h^h^h^hshooterCommented:
Okay, confirming more assumptions:
You mentioned the domain functional level (at 2008 R2)... is the forest functional level at least 2003?
Confirm the DFS namespace is domain-based, not stand alone?
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

lsysamcAuthor Commented:
The domain functional level is also 2008r2.  I'm trying to create a domain based Namespace but it won't let me check the 2008 mode check box.  Right now there are no other namespaces.
0
Rich WeisslerProfessional Troublemaker^h^h^h^h^hshooterCommented:
If the 2008 mode check box is greyed out, it would indicate you don't meet the prerequisite.  I realize the domain functional level is 2008 R2.  Can you also confirm the forest functional level, please?  (In current versions of Powershell, you can run "(Get-ADForest).ForestMode" to output the forest functional level...)
0
lsysamcAuthor Commented:
Sorry, I meant the forest functional level is also 2008 r2.  I was figuring I'm missing a prerequisite but I can't seem to find what I'm missing.
0
Rich WeisslerProfessional Troublemaker^h^h^h^h^hshooterCommented:
Excellent.  Double check "dfsutil /pktinfo" to make certain you don't have any unexpected namespace servers.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
lsysamcAuthor Commented:
Think you may be onto something there but the result is strange.  I have setup a total of 2 DFS servers both server 2012 r2.  Both get the same grayed out checkbox.  The second DFS server is offsite though and connected via vpn tunnel.  

When I run the command from the primary DFS server I'm working at now I get 2 entrys.  1 is the offsite server.  The other is a 2008 server I was not expecting.  I just checked the roles on that server though and DFS is not installed.

When I run the command from the offsite dns server it only has 1 entry and that is itself.
0
lsysamcAuthor Commented:
Sorry that last line was supposed to read:

When I run the command from the offsite DFS server it only has 1 entry and that is itself.
0
lsysamcAuthor Commented:
Just to give an update, I did find an old dfs server but it was on a different domain here.  I removed all the root namespaces but couldn't actually remove the role from the server.  Having problems getting rid of it because it's server 2003 web edition, but thats a different problem.

Either way, even after removing all the root namespaces and manually removing them from the second domain in AD the 2008 checkbox was still grey'd out when trying to create a domain namespace.  

I tried creating the namespace using the dfsutil command line utility though and it did create the namespace in 2008 mode.  Not sure why this works but the gui won't let us choose it.
0
lsysamcAuthor Commented:
Well it's fixed now but I'm not sure why.  Last thing I did was add the DfsDnsConfig regdword (set to 1) and now I can set 2008 mode in the gui...  Thanks for your help though.  Definitely put me on the right path.
0
lsysamcAuthor Commented:
The experts post definitely led me down the right path but it wasn't the full solution.  Wanted to mark the full solution as well.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.