HP 2910al firmware upgrade

I am attempting to upload the newest firmware to a bunch of our HP 2910al 48g switches.  But I have been unsuccessful .  I've tried TFTP via the command line but I get an error showing 0 bytes were uploaded.  The log file on the TFTP server never even showed any login attempts , it simply gave me an instant error.

I also tried  uploading using our Procurve manager software but The Procurve manager gives an error stating TFTP is not  enabled on the switch.

So my two questions are:
1) should I use something other than TFTP ?
OR
2) if TFTP is still a valid option for my local network, how do I "enable" it on the switch?
mathewsitdeptAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Michael DyerSenior Systems Support AnalystCommented:
It sounds like TFTP is disabled on the switch.  This is often done for security reasons since TFTP is not secure.  You can try using SFTP if this is enabled or you can enable TFTP long enough to load the firmware.  

You can also copy firmware in from a USB drive.  Attached is a copy of the Management and Configuration guide with full instructions.  2910-MCG-Feb09-W_14_03.pdf
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mathewsitdeptAuthor Commented:
Thank you so much for the manual.  
You were correct, the TFTP was turned off inside the switch.

In case others read this, the method to turn the TFTP on and off can be found by doing this:
Login to the switch
Go into config mode by typing CONFIG
then from the prompt type this to turn on TFTP
# tftp client
OR to turn off TFTP from the prompt type this:
# off tftp client

Thanks again for the help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.