IE 11 "A website wants to open web content using this program on your computer" how to eliminate of this message?

I am working on someones W7 laptop and in IE 11 she was continually getting the message "A website wants to open web content using this program on your computer" It listed IE 11 as the Name and Microsoft as the publlisher. I read somewhere that disabling the shockwave addin would help, so far it has not happened again. Is that the solution?
techhelptrainerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
If the request is legitimate, it will tell you what program it needs.

More likely it is a virus. Scan with your own anti virus application and then scan with Malwarebytes in Safe Mode.
0
Tapan PattanaikSenior EngineerCommented:
Hi techhelptrainer,

This is a cool security feature of Protected Mode in Internet Explorer that ask (alert message) and verify if you will allow a program to run the program from IE. So, any bad guys out there cannot automatically run a program from just opening a malicious website. Great!!!

"This program does not have a valid digital signature that verifies its publisher. This program will open outside of Protected mode, putting your computer at risk. You should only run programs from publishers you trust."

1) Is your issue with a particular website or for all websites?
2) Does it show the name and publisher of the file that it is trying to open?


To work with this issue please follow below methods.

Method 1:

Please Run the Microsoft fixit for IE.

Improve performance, safety and security in Internet Explorer
https://support.microsoft.com/en-us/mats/ie_performance_and_safety/en-us
 
About Internet Explorer Pop-up Blocker:

Here you can obtain information on blocking specific pop-ups.
http://windows.microsoft.com/en-us/internet-explorer/ie-security-privacy-settings#ie=ie-11&pop-up_blocker

Method 2:

 Enable the following settings on Internet Explorer 11 and check if it helps.

i)   Open IE 11
ii)  Select the Tools option and click on Internet Options.
iii) In the Security Tab select the Trusted sites Zone and click on Custom level
iv)  Scroll down and enable the option Display mixed contents.
v)   Also enable the option don’t prompt for client certificate selection when no certificates.
vi)  Click on Ok and restart  the Internet Explorer.
 
Check if it helps.

Method 3:

Please scan your system with Good antivirus
i)http://www.kaspersky.com/internet-security-trial
ii)https://www.malwarebytes.org/mwb-download/

Regards,
Tapan Pattanaik
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
techhelptrainerAuthor Commented:
Thanks for the repsonses and information. I have not seen the message again since I disabled the Shockwave flash addin. Malwarebytes did not find any problems. I will return it to the customer and see if they report anymore problems
1
JohnBusiness Consultant (Owner)Commented:
@techhelptrainer - Thanks for your update and I was happy to help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.