Unable to attach USB devices to virtual machines in VMware ESX 5.5 on ASUS T700 Server

We are unable to attach a USB device to a virtual machine.
the USB drives do not show up in the list of devices that can be added.

I have tried adding both of the USB host controllers but when I plug in any USB device and attempt to add this to the virtual machine the device does not show up in the list .

Can only see :
American Megatrends Virtual Floppy device
American Megatrends Virtual HardDisk Device
LVL 1
KCITSAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
I've been discussing this issue with VMware Support for many years, since USB passthrough was introduced as a feature!

basically the bottom line is, do not assume, that because you have a USB device, VMware vSphere supports USB passthrough, your device is going to work, and passthrough to the VM. (unless on the stupid what VMware called the USB HCL list, which I've listed in this post, which is stupid, because most of those devices no longer exist or are can be obtained).

check your logs...../var/log, dmesg, or usb.log for details, if the device shows as supported! Also because you are running on a whitebox, non-HCL server, the support is also limited further.

Workarounds, are using VM Direct Path I/O to passthrough the physical USB controller to the VM, or use a Digi USB-Anywhere box, or software e.g. Fabultech USB over network.

Please see my EE Article

HOW TO: Add and Connect a USB Device to a Virtual Machine, hosted on VMware vSphere Hypervisor ESX 4.1 ESXi 4.1, ESXi 5.0

and this...

you can read the outcome here....

http://www.experts-exchange.com/discussions/209901/VMware-Support-Test-for-USB-Passthrough-issue.html

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1021345

and basically the support engineer agreed with me on the following points....

IF YOU HAVE A DEVICE WHICH IS NOT ON THE ABOVE LIST DO NOT EXPECT IT TO WORK WITHIN VMWARE VSPHERE IN USB PASSTHROUGH MODE.

he did however, also agree, that it is a very short list, and he thought they must have tested more devices by now!!!!

because although updated in 2015, that was just to add the 6.0 reference!
0
KCITSAuthor Commented:
Hi thanks Andrew
Very good info, however I am a bit confused as after adding the USB controller I can select to add a USB Device (which was previously greyed out)

And there are USB devices to add but only
 `American Megatrends Virtual Floppy device`
 `American Megatrends Virtual HardDisk Device`

The USB.log does not mention anything is unsupported however it does contain the below errors.
BTW I upgraded to ESX 6 but still no change,

USB.log
2015-11-01T22:07:40Z usbarb[33865]: I120: VTHREAD initialize main thread 2 "usbArb" pid 33865
2015-11-01T22:07:40Z usbarb[33865]: I120: PREF Optional preferences file not found at /usr/lib/vmware/config. Using default values.
2015-11-01T22:07:40Z usbarb[33865]: I120: PREF Optional preferences file not found at //.vmware/config. Using default values.
2015-11-01T22:07:40Z usbarb[33865]: I120: PREF Disabling user preferences because disableUserPreferences is set.
2015-11-01T22:07:40Z usbarb[33865]: I120: PREF Failed to load user preferences.
2015-11-01T22:07:40Z usbarb[33865]: I120: DICT --- USER PREFERENCES
2015-11-01T22:07:40Z usbarb[33865]: I120: DICT --- USER DEFAULTS //.vmware/config
2015-11-01T22:07:40Z usbarb[33865]: I120: DICT --- HOST DEFAULTS /etc/vmware/config
2015-11-01T22:07:40Z usbarb[33865]: I120: DICT                    libdir = /usr/lib/vmware
2015-11-01T22:07:40Z usbarb[33865]: I120: DICT           authd.proxy.nfc = vmware-hostd:ha-nfc
2015-11-01T22:07:40Z usbarb[33865]: I120: DICT        authd.proxy.nfcssl = vmware-hostd:ha-nfcssl
2015-11-01T22:07:40Z usbarb[33865]: I120: DICT   authd.proxy.vpxa-nfcssl = vmware-vpxa:vpxa-nfcssl
2015-11-01T22:07:40Z usbarb[33865]: I120: DICT      authd.proxy.vpxa-nfc = vmware-vpxa:vpxa-nfc
2015-11-01T22:07:40Z usbarb[33865]: I120: DICT            authd.fullpath = /sbin/authd
2015-11-01T22:07:40Z usbarb[33865]: I120: DICT --- SITE DEFAULTS /usr/lib/vmware/config
2015-11-01T22:07:40Z usbarb[33865]: W110: USBArb: Error in rules file at line 1:0, '[' or '{' expected near end of file.
2015-11-01T22:07:40Z usbarb[33865]: I120: VMware USB Arbitration Service Version 11.1.6
2015-11-01T22:07:40Z usbarb[33865]: I120: USBArb: Attempting to connect to existing arbitrator on /var/run/vmware/usbarbitrator-socket.
2015-11-01T22:07:40Z usbarb[33865]: I120: SOCKET creating new socket, connecting to /var/run/vmware/usbarbitrator-socket
2015-11-01T22:07:40Z usbarb[33865]: W110: SOCKET connect failed, error 2: No such file or directory
2015-11-01T22:07:40Z usbarb[33865]: I120: USBArb: Failed to connect to the existing arbitrator.
2015-11-01T22:07:52Z usbarb[33865]: I120: USBArb: UsbArbPipeConnected: Connected to client, socket:13
2015-11-01T22:07:52Z usbarb[33865]: I120: USBArb: Client 33987 connected (version: 6)
0
KCITSAuthor Commented:
Just to add:  we have installed the same version (ISO) of ESX on an Intel server and are using the same USB devices and they are able to be successfully added and used.

Maybe the actual ASUS USB controllers are not compatible, this is frustrating as we have not had this issue on other ASUS server previously, and really need to use Tandberg backup drives on this host.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
if the device you are trying to add, does not appear as a device you can add as per my EE Article, it's not supported, if your device is on the supported list, it's also not supported, and cannot be guaranteed to work!

It's as simple as that I'm afraid!

anything in the /var/log when you insert the usb device.

Using USB passthrough is very slow, as the I/O is virtualised!

again, if your USB device is not on the tested VMware list, it's not supported, and unlikely to work! if it does work you are just lucky!
0
KCITSAuthor Commented:
Seems like we have isolated an easy fix for this. After a BIOS update we turned off Legacy USB support in the BIOS and we can now see all plugged in USB devices. Without fault

Previously only the motherboard virtual USB devices were visible.
(American Megatrends Virtual Floppy device)
 (American Megatrends Virtual HardDisk Device)  

Also thanks to Andrew, I will assign some points to you also as your article was helpful in diagnosing the fault by locating the log files on the ESX host.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
KCITSAuthor Commented:
Fault was resolved by turning off Legacy USB support in the BIOS,

Points were also awarded to Andrew for his support and article on diagnosing USB errors on ESXi
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.