Assistance with MLPPP

We need config assistance in getting MLPPP working for bonding 4x DSL lines back to our LNS (CISCO ASR 1001).
aussieandyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bamsiCommented:
try the following commands

interface <insert interface>
 encapsulation ppp
 ppp multilink
 ppp multilink group <insert multilink #>
 exit

then a multilink interface should show up on your router.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
aussieandyAuthor Commented:
This is the current config we are running with, however the service just wont stay up as a multilinked bundle..

ip name-server 8.8.8.8
multilink bundle-name authenticated
!
!
class-map match-all gold
 match access-group 148
class-map match-all plat
 match access-group 149
class-map match-all bronze
 match access-group 146
class-map match-all silver
 match access-group 147
class-map match-any silver_out
 description Match Customer traffic maked as Silver
 match ip precedence 3
class-map match-any gold_out
 description Match Customer traffic maked as Gold
 match ip precedence 4
 match access-group 148
class-map match-any plat_out
 description Match Customer traffic maked as VoIP
 match ip precedence 5
class-map match-any bronze_out
 description Match Customer traffic maked as Bronze
 match ip precedence 2
!
!
policy-map qosout
 description Enhanced QoS customers outbound Percentages
 class plat_out
  priority percent 30
 class gold_out
  bandwidth percent 30
 class silver_out
  bandwidth percent 13
 class bronze_out
  bandwidth percent 2
 class class-default
  fair-queue
policy-map qosin
 class plat
  set ip precedence 5
 class gold
  set ip precedence 4
 class silver
  set ip precedence 3
 class bronze
  set ip precedence 2
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description LAN for test
 mtu 1450
 ip address 10.0.0.1 255.255.255.0
 ip mtu 1400
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
!
interface ATM0/0/0
 no ip address
 no atm ilmi-keepalive
 pvc 8/35
  vbr-nrt 1000 500 20
  tx-ring-limit 3
  encapsulation aal5snap
  service-policy out qosout
  pppoe-client dial-pool-number 1
 !
!
interface ATM0/1/0
 no ip address
 no atm ilmi-keepalive
 pvc 8/35
  vbr-nrt 1000 500 20
  tx-ring-limit 3
  encapsulation aal5snap
  service-policy out qosout
  pppoe-client dial-pool-number 1
 !
!
interface ATM0/2/0
 no ip address
 no atm ilmi-keepalive
 pvc 8/35
  vbr-nrt 1000 500 20
  tx-ring-limit 3
  encapsulation aal5snap
  service-policy out qosout
  pppoe-client dial-pool-number 1
 !
!
interface ATM0/3/0
 no ip address
 no atm ilmi-keepalive
 pvc 8/35
  vbr-nrt 1000 500 20
  tx-ring-limit 3
  encapsulation aal5snap
  service-policy out qosout
  pppoe-client dial-pool-number 1
 !
!
interface Dialer1
 description --- MLPP
 bandwidth 4000
 ip address negotiated
 ip mtu 1460
 ip load-sharing per-packet
 ip flow ingress
 ip flow egress
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1350
 tx-ring-limit 3
 tx-queue-limit 3
 dialer pool 1
 dialer-group 1
 keepalive 30
 ppp max-configure 30
 ppp max-failure 30
 ppp lcp predictive
 ppp lcp delay 10
 ppp chap hostname xxx
 ppp chap password xxx
 ppp ipcp predictive
 ppp multilink
 ppp multilink links minimum 2
 ppp multilink interleave
 ppp multilink fragment size 1300
 ppp timeout retry 5
 service-policy output qosout
!
ip forward-protocol nd
!
no ip http server
ip http secure-server
ip flow-export version 9
ip flow-export destination 10.255.255.1 2055
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
!
bamsiCommented:
what errors do you see on the logs? i see CHAP is configured, have you check if passwords are correct on both ends?

edit:

i think this document can help you a lot:

http://www.cisco.com/c/en/us/support/docs/long-reach-ethernet-lre-digital-subscriber-line-xdsl/asymmetric-digital-subscriber-line-adsl/12964-wicadsl-pppoe-client.html
MikeIT ProfessionalCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.

I have recommended this question be closed as follows:

Accept: bamsi (https:#a41174244)

If you feel this question should be closed differently, post an objection and the moderators will review all objections and close it as they feel fit. If no one objects, this question will be closed automatically the way described above.

FireRunt
Experts-Exchange Cleanup Volunteer
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.