NetApp Volume Extended Windows no seeing it

I did not setup our NetAPP orginally but users connect to volumes by going to \\<servername\share. I extended a volume on aggr1 logged off and logged in again and windows saw the new size. I did the same for a volume on aggr0 but windows does not show the correct size and have confirmed the Netapp did allocate the space for the volume????

What am I doing wrong here?
LVL 21
compdigit44Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

compdigit44Author Commented:
I found my volume as a maxdirsize set to 4194303 and think this is preventing the volume from growthing.. I an 90% there is a quote on the volume and trying to figure out how to increase it.
robocatCommented:
Maxdirsize has nothing to do with this, don't mess with this.

There are several reasons why you might not see a larger volume size, e.g. if you use Quota or if this is a LUN.

What does the Netapp report as volume size and what do you see in Windows?
compdigit44Author Commented:
I am not connected to my network right now but it is not a Lun but a CIFS share... Also I cannot use OnCommand since it is message update and not longer give me the option to expand to change volume sizes....
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

compdigit44Author Commented:
If I am reading the report in OnCommand correctly there is a quota on the volume. But as I noticed before the ONCommand client does not give me any options to change anything on a volume like size, quotes etc ... must use command line which support usually helping me with but our support was not renewed ... Any suggstions?
robocatCommented:
By "oncommand client", you do mean oncommand system manager, right?

I ask this question because Netapp has multiple tools under the oncommand brand name and you do need system manager to manage your system.
compdigit44Author Commented:
I am not great with Netapp but what is installed is oncommand host I believe and system manager...

Only thing I know is that I can look at everything in the GUI but cannot edit anything.

Can my issues be correct via the command line. I ask since the volume is low on space which is why I looked up how to expand it via the command line
robocatCommented:
CLI commands for resizing volumes:

https://library.netapp.com/ecmdocs/ECMP1368859/html/GUID-24010000-3EEA-46AD-A35C-16D63D99F3D5.html

So example (after you check that there's enough free space in the aggregate!):

vol size /vol/myvolumethatisnotbigenough +10g

Using the GUI is the preferred method however, because it will prevent you from making mistakes.  Perhaps you login with a user without change permissions?
compdigit44Author Commented:
I ran the above command before to expand the volume which did work the problem is windows is not seeing the new size of the CIFS share and I have confirmed the volume did expand on the NetAPP size. The account I am logged in with is the old account used to admin the NetApp by the previous admin
robocatCommented:
In system manager, go to volumes and click on the volume you're talking about.

At the bottom of the screen,  there are 4 tabs: details, space allocation, snapshot copies and storage efficiency.

Could you make a screenshot of all 4 tabs and post these here?
compdigit44Author Commented:
I was traveling today and will take a look at this tomorrow..

If this cannot be done in the GUI how would edit the quota via command line?
compdigit44Author Commented:
I checked System Manager like I have done before and do not have a volumes tab and only give me dashboard views and yes I have tried to click through each screen. I am certain this issue has to do with a quote on the volume but do not know how to adjust the quota for the new size via the command line
robocatCommented:
I'm starting to believe that you don't have System Manager but some other product of the Oncommand suite.  It should look something link this:

sm.jpg
System Manager is the only product that will allow you manage the Netapp. The other products are for alerting and reporting but don't allow any changes. Please confirm that you have System Manager or not.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
compdigit44Author Commented:
My dashboard for System Manager looks nothing like yours.. How else can I correct this without the GUI?
ScreenShot.png
robocatCommented:
This is not system manager and is the reason why you can't manage your netapp. The tool you have is for monitoring purposes.

You need to get hold of system manager, this is the (free) tool that comes with each Netapp. It is a simple install on your pc and requires no server.
compdigit44Author Commented:
Where can I download it if I do not have a valid support contact any more?
robocatCommented:
I'm pretty sure the Netapp support site is the only place you can download it.

If you don't have an account, you can make one for yourself. Not sure how much you can download without a contract, but because this is a free tool that comes with each system, it might be possible.

If not, you can always ask them nicely.
compdigit44Author Commented:
what version should I try to download?
compdigit44Author Commented:
I am having problem getting system manager.... how can I fix this via the command line???

Thank you for sticking with me on this

I am not sure if this helps or not but I have attached a screen shot of what my OnCommand console looks like....
OnCommand.png
robocatCommented:
You (probably) need System Manager 3.1.2, dependig on the version of Ontap you're running.

In order to be able to manage your system , you do need System Manager.

Although many things can be done command line, this is only so if you're an experienced admin. There's too many things that we still need to check before we can fix the problem. And there's too much room for error (which could completely mess up your system) if you try fixing it with the CLI.

So even if this is not easy, you will need to get System Manager.
compdigit44Author Commented:
Have you found a download link?
robocatCommented:
support.netapp.com -> downloads

See my earlier comments about this download.
compdigit44Author Commented:
I did that but keep getting a unauthorized message...
robocatCommented:
Did you contact Netapp to ask if they can authorize your account for purpose of downloading system manager?
compdigit44Author Commented:
After talking for support for a while there were able to correct my account issues and was able to download System Manager 3.2.1. I have it installed now but need to read the instruction on how to detection my NetApp... I will keep you posted.
compdigit44Author Commented:
I got my netapp not listed in System Manger...  The stats on the volumes show 700GB but windows still shows...500GB. I ran through the resize wize but it made not difference...
compdigit44Author Commented:
I figured it out !!!

I found the quotes folder and updated the values to the new size and windows saw more space...

I noticed that the netapp shows as the volume size and what windows sees differs but I have read this is normal and has do to with the way the two OS calculate disk space..

Is this correct.
robocatCommented:
You will loose some space due to Netapp snapshots.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.