External Hard Drive can't be recognized by Windows

Hi all.
First, let me confess the question title is not precise: I apologize, but I didn't find a short way to describe the real problem.
My External drive works good, it contains a lot of file and I can access them easily. But to access it I first have to unplug it, then turn it on and finally plug it in again: if I turn it on whit USB cable plugged in Windows doesn't recognize it at all.
It's not a tragedy, but I'd like to fix this to get a more comfortable access to my files :-)
Any idea?

Using Windows 10, but thiss happened even on Windows 7 and 8.0 and 8.1
LVL 32
Marco GasiFreelancerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

diperspCommented:
I would check with your computer vendor to see if there are any updated drivers.  I would also especially look at Intel (If you have an Intel) for updated chipset and/or USB drivers.  Many times the manufacturers won't have anything updated, but Intel will.

What's the make/model of the computer?
noxchoGlobal Support CoordinatorCommented:
Does it not show up or is the problem in missing drive letter?
Once you turn it on with USB cable connected - please go to Windows Disk Management (right click on My Computer - Manage - Disk Management).
Does it show up there with no drive letter assigned?
Marco GasiFreelancerAuthor Commented:
Thank you for your reply dipersp.
I have an Acer with Intel Celeron 1.60 Ghz. I tried to update drivers using Windows utility but it tells the driver is updated.
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

diperspCommented:
Windows Update is useless for driver updates.

Try this from Intel -

http://www.intel.com/p/en_US/support/detect
Benjamin VoglarIT ProCommented:
I had exactly the same problem.
I fixed it so, that I first replaced the USB CABLE and then i upgraded the Firmware of USB Disk.
noxchoGlobal Support CoordinatorCommented:
Is the drive detected at all when you turn it on with a cable connected?
GauthierCommented:
The problem lies with the drive usb port not notifying the usb stack of a drive power up. It was probably recognized as something else before the power-up.
So it's a drive defect and no change to Windows can solve it.

Possibly depending on the kind of conception defect you could solve it with one of the following procedure:

1- Trigger an hardware scan within an elevated command prompt:
echo rescan | diskpart
2- Remove the USB device corresponding to the drive from the device manager and scan for hardware changes after powering it up.
But I do not think it is possible to automate it easily, There are ways to trigger a scan (see 1), but the PowerShell API so far only allow for a disable/enable device, not a removal.

3 Alternatively, try powering the drive before the computer and then turn it of after the boot. A rescan after powerup by solution 1 may then work.
Marco GasiFreelancerAuthor Commented:
@noxcho: I apologize: I didn't see your comment: yes the drive has its letter correctly assigned.
@dipersp: I'm going to check it. Thank you.
noxchoGlobal Support CoordinatorCommented:
@noxcho: I apologize: I didn't see your comment: yes the drive has its letter correctly assigned.
Even when it fails to show up in Windows? You wrote:
if I turn it on whit USB cable plugged in Windows doesn't recognize it at all.
- when this happens, go to Windows Disk Management and check if the drive is there.
Marco GasiFreelancerAuthor Commented:
@Benjamin Voglar: how can I update external hd firmware?

@noxcho: No, when I trun on the disk, the disk appears in Disk management but without letter: an upvote to you :-) It says unknown

@Gauthier: I'm going to try step 3 because it looks to be the quickest one to try

@dipersp: Intel utility just installed graphic drivers: no change :-(
diperspCommented:
Yeh, I think most of those update utilities don't work.  Figured try that first.

I'd check out https://downloadcenter.intel.com/download/20775/Intel-Chipset-Device-Software-INF-Update-Utility- and see if it's compatible.
Marco GasiFreelancerAuthor Commented:
Uh, uh, now I did something really bad! In Disk Management I right clicked on the disk and I've choosen
Initialize as MBR because as GPT disk it said it was impossible and now I definitely can't access data! In Disk Manager it defines 698 GB as unallocated...
Marco GasiFreelancerAuthor Commented:
@dipersp: they say the software wont correct no agp or usb driver issue...
**Important**
The Intel Chipset Device Software does not install drivers for AGP or USB. DO NOT DOWNLOAD THIS UTILITY IF YOUR DEVICE MANUFACTURER IS RECOMMENDING IT TO CORRECT AN "AGP DRIVER," "AGP GART," OR "USB DRIVER" ISSUE; IT WILL NOT CORRECT YOUR ISSUE.
noxchoGlobal Support CoordinatorCommented:
That was not the good idea. But the data is still there. No panic. Disconnect it - turn on and then connect. See if it shows data.
If not then you need to use Undelete Partition. Use either one of Paragon tools such as Hard Disk Manager 15 or Active Undelete Partition Wizard.
Marco GasiFreelancerAuthor Commented:
ok, thank you. I'll do it later because unfortunately now I have to go away before to solve the problem :-|.
I'll let you know asap
tmoore1962Commented:
Try turning off power management for your USB ports in Device Manager.
Marco GasiFreelancerAuthor Commented:
@tmoore1962: thank you for your suggestion. Now I'm running Active Undelete to scan the disk: it's a long process so I must wait for it to see if it works to repair my stupid action. Then I'll can come back to the original question and I'll try to do what you said :-)
Marco GasiFreelancerAuthor Commented:
But where I find the command to turn off power management in Device Manager? I can't see it...
noxchoGlobal Support CoordinatorCommented:
Did the undelete find anything? Note, before you run it the drive must be connected the way it worked before. Means you turn it first on and then connect the cable. After that run undelete wizard. If it fails you have to use GetDataBack from runtime.org
Marco GasiFreelancerAuthor Commented:
Undelete is taking a long time to scan: it started at18:00 more or less and it's still at 71%. But I see the HD led which blinks notifying operations and undelete says it found 10 partitions (!) The first, with status 'excellent' should be the one I want.
I'll let you know results later or tomorrow morning. I'll take a look at GetDataBack also, thank you.
noxchoGlobal Support CoordinatorCommented:
Ok. Before you click undelete the found partition look its used space and size. If it is the one you are missing. And only then click proceed.
Marco GasiFreelancerAuthor Commented:
Roger ;-)
Marco GasiFreelancerAuthor Commented:
@noxcho: mmmhh, I think I'm using the wrong program version: once the scan has been completed it doesn't offer me the option to recover partition but just to scan for files and then recover them in another location...
Is it possible to recover in the same origin HD?
Do I have to buy the full version of undelete to have the option to recover the partition?

Thank you
nobusCommented:
the best software for recovering data is GetDataback - and it is very reasonably priced
Also it shows what it can recover, before you need to buy it
http://www.runtime.org/

as for your usb problem, i found safelyRemove very good (not free) :
http://safelyremove.com/?pid=1
noxchoGlobal Support CoordinatorCommented:
As an active member of Experts-Exchange community you can get a Hard Disk Manager 15 from Paragon for free. And it has undelete lost partitions wizard as well. Ask for your copy at Paragon and do the scan with this tool.

Moderator Edit 11/3/2015: This was an old program on a limited license that is possibly defunct and no longer available.  
Marco GasiFreelancerAuthor Commented:
Thanks noxcho, but I have to contact them because when I click submit button to request the software I get an error message about a not found script :-)
@nobus thank to you too I'll try them, but GetDataBack was yet notified bt noxcho...
Marco GasiFreelancerAuthor Commented:
Hi all. Waiting for Paragon's email (the one to confirm account and the one in response to my support request) I'm hapy to announce my partition has been restored!
So we can go back to the original question.
@nobus: I remember in the past I didn't need any 3rd party software to mount and unmount hard disks: I think here it's a specific problem I wish to definitely fix.

In Disk Management, when I turn on the hd and it is connected yet, the disk appears but not initialized: if I right click on the button and I choos Initilize, the disk wakes up and Explorer opens a window on it.
Marco GasiFreelancerAuthor Commented:
@noxcho: does it exist a page at EE where are listed partnerships we can take advatantage from? If not, how did you know the convention with Paragon? Thank you
noxchoGlobal Support CoordinatorCommented:
Got in early 2010 someone from Paragon pointing me to that advisory council. And I share this information between experts here :)
But I think we do not have here in EE such a list. Though the idea would be excellent.
Marco GasiFreelancerAuthor Commented:
Lol, now it is working for me too! After a restart... Well, what do you suggest about the 'main' issue?
I tried everything but nothing seems to work.
Marco GasiFreelancerAuthor Commented:
In administrator command prompt I did this:
DISKPART> SELECT DISK n (n is the disk number)
DISKPART> ATTRIBUTES DISK CLEAR READONLY

Open in new window

I did this with the disk connected and turned on: it was not initialized. I'd just removed readonly, the disck is initialized and Explorers open on it.
Turned off the disk, closed explorer, turned on the disk and it works! But if I repeat a third time, the disk is not initialized again and have to clear readonly again...
noxchoGlobal Support CoordinatorCommented:
What kind of disk is this? Is this a 3.5 drive in some powered USB box?
What I would try is - another USB disk and check if the problem is reproducible.
Once the disk is detected and working - run on it CHKDSK x:/f where X: is your drive letter.
Plus check via regedit: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\mountmgr
NoAutoMount key.
Its value must be 0.
Marco GasiFreelancerAuthor Commented:
It's a Samsung Lacie HD 3.5, nothing special, I think...
- No the problem is not reproducible: another disk starts as expected.
- chkdsk finds no problem
- NoAutoMountKey was not present: I've created it and set it to 0
Restarted the pc, everything remains the same
noxchoGlobal Support CoordinatorCommented:
Ok, the problem is in the USB box then. Either replace it or use your method always which works - first turn on the drive, then connect it.
Just thinking loud - it could be that some electronic parts of the box are collecting the energy first and then giving it to the drive. And when turned on already connected - the PC gets the signal from the drive which is incomplete. Which is not the case when you first turn the drive on and then connect it to PC.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Marco GasiFreelancerAuthor Commented:
Thank you all for your time and effort. I awarded 100 points to dipesrp for having provided a generally useful link and the rest to noxcho because he finally found the problem and the possible solution: I'll stay as I was :-)
Thank you again
Marco GasiFreelancerAuthor Commented:
@noxcho you probably missed my curiosity: there is a page in EE site which lists all agreements between EE and software houses similar to the one between EE and Paragon Software? It could be a useful resource indeed! :-)
noxchoGlobal Support CoordinatorCommented:
I answered it here ID: 41180250:
But I think we do not have here in EE such a list. Though the idea would be excellent.
Marco GasiFreelancerAuthor Commented:
Ooops, I totally missed it. Thank you again
noxchoGlobal Support CoordinatorCommented:
You are welcome!
Take care.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Hardware

From novice to tech pro — start learning today.