windows 7 install setup unable to create a new system partition

I'm trying to downgrade to Windows 7 32-bit for a legacy PLC computer. I created a USB disk with the proper ISO using the Windows 7 USB DVD Download Tool. Booted in, selected the drive and get "setup unable to create a new system partition". I went to advanced removed the partitions still no luck. So I took the following steps.

Backed out to the cmd prompt.

Diskpart
list disk
select disk 0
Clean all
create partition primary size=200
format fs=ntfs label="System Reserved" quick
active
create partition primary
format fs=ntfs label="Windows 7" quick
active
exit

Restart, try to install to Windows 7 disk, still no luck. Any other ideas?
bhiebAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bhiebAuthor Commented:
Just to give some more information. This is a new Intel NUC PC with a mSata SSD.  

I've checked the sata mode and it is set to AHCI, I've tried both UEFI and legacy with no change, same error.
jcimarronCommented:
bhieb--
Use Easeus Partition Manager ( there is a free version)
http://www.partition-tool.com/
bhiebAuthor Commented:
What would you like me to do with that? This is a clean install on a disk with no partitions defined.
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

bhiebAuthor Commented:
Just to rule it out, I tried the 64bit iso with the same results.
jcimarronCommented:
bhieb--
"What would you like me to do with that?"
Your question seems to be "how to create a new system partition"
bhiebAuthor Commented:
No, how to get around this installation error. In theory windows install should take care of all the partitioning, but it is failing to do so. Even after using diskpart to clear the partitions and install onto the unallocated space.
Dan CraciunIT ConsultantCommented:
It's GPT or MBR?

MBR should work with AHCI or legacy, GPT for UEFI.

Test in diskpart the type of partitioning.

HTH,
Dan
bhiebAuthor Commented:
It is set to MBR, which is fine since it is only 120GB, and going to be a 32bit environment.
noxchoGlobal Support CoordinatorCommented:
If you have a USB DVD device then try to install from it. Instead of using USB Stick. I have had similar problem when trying to install from USB stick and it worked for me always when installing from DVD media.
bhiebAuthor Commented:
Noxcho, thanks I've got one on order hopefully that may do the trick. Running out of options.
marsiliesCommented:
Per the discussion at this link, it looks like trying to install from a USB 3.0 stick could cause the issue. Booting from a DVD will work, but also using a USB 2.0 stick will as well:
http://www.sevenforums.com/installation-setup/330271-setup-unable-create-new-system-partition-3.html#post2818746
I was lucky enough to have a DVD drive in my freshly bought Lenovo B590, and with a DVD, the installation went past the point of partitioning and finished as it was supposed.

But this was not an acceptable solution, so I went back to make it work with the USB. In my case, the problem seemed to arise from the fact that I was trying to use a usb 3.0 stick. However, as we all know, the installation process doesn't natively support usb 3.0 yet. But one would think it's not an issue, both the system and the os should fall back to 2.0, and this shouldn't cause any issues. WRONG!

I couldn't test it yet, but I guess it that for some strange reason, the 2.0 mode doesn't work properly if your stick is already 3.0 capable. When trying to use the 3.0 slot, i came to the point where it asked me for a driver, so then I assumed it's easier to use the 2.0 slot on the other side of the machine. Wrong path, as it turned out, as I then got to the infamous "'windows 7 setup was unable to create a new partition bla bla bla" error.

http://www.sevenforums.com/installation-setup/330271-setup-unable-create-new-system-partition-4.html#post3003289
I am working on a NUC that is all USB 3.0 ports, my USB stick is USB 3.0, failed at every attempt no matter what. Grabbed a USB 2.0 stick, imaged (with the exact same image & settings as the 3.0). Sailed through first time.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bhiebAuthor Commented:
Nailed it you 2, from usb dvd it works fine. Ironically even using the USB 3.0 stick through a 2.0 hub did no good. I didn't have a USB 2.0 drive around.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Operating Systems

From novice to tech pro — start learning today.