cannot start TFTP sever in RHEL 7

I attempt to start TFTP service with

sudo systemctl start tftpd.service

and I get

Failed to issue method call: Unit tftpd.service failed to load: No such file or directory.

but it does exist

[root@i-pcicapsule /]# find -name "tftp"
./etc/xinetd.d/tftp
./usr/share/katello-installer/modules/foreman_proxy/manifests/tftp
./usr/share/katello-installer/modules/tftp
./usr/share/foreman-proxy/modules/tftp
[root@i-pcicapsule /]#

I am baffled please help!!!
LVL 1
NAMEWITHELD12Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

zalazarCommented:
Did you already check the configuration file /etc/xinetd.d/tftp
Can you maybe post the contents of this file ?
Within the "service tftp" section, disable should be set to no
disable         = no

If this is the case, the could you please try:
systemctl start xinetd
arnoldCommented:
Tftpd is a service runs under xinetd
/etc/xinetd.d

As zalastar pointed out if you are activating all you need to do is reload xinetd.
NAMEWITHELD12Author Commented:
it seems that this is running outside the service

how can I get this to run as a service?

[root@i-pcicapsule xinetd.d]# ps -ef | grep tftp
root     14142 10875  0 09:48 pts/0    00:00:00 grep --color=auto tftp



thanks
arnoldCommented:
You received in the response what you were searching for.
Tftp is either run under xinetd(xinetd is the monitoring service on the network and when a connection attempt is made will start the in.tftpd
To run tftpd independently, you have to use a TCP service/port monitor that will start the application when the connection is seen.
zalazarCommented:
You could try to use the tftp.socket.
To start with a clean config you might remove the current packages first via:
yum remove xinetd tftp-server tftp
Then install the pacakges again via:
yum install xinetd tftp-server tftp

By default the tftp.socket service only listens on IPv6 addresses.
If you also need IPv4 then please modify
/usr/lib/systemd/system/tftp.socket
and change
ListenDatagram=69
to
ListenDatagram=0.0.0.0:69
ListenDatagram=[::]:69

Enable and start the service via:
systemctl enable tftp.socket
systemctl start tftp.socket

Then check that the service is listening on port 69/UDP via:
netstat -tulpen |grep 69

To allow TFTP if the firewall is enabled:
firewall-cmd --add-port=69/udp --permanent
firewall-cmd --reload

Please also make sure that SELinux is not blocking.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.