Connecting to a WPA wifi network using Windows 10

simoncooper999
simoncooper999 used Ask the Experts™
on
Hi

I have a corporate wifi network setup using WPA, when I try to connect a Windows 10 laptop to it, I dont have the option to use WPA, I only get WEP or WPA2.

I read a page that used the netsh prompt to edit the network profile but that came back and said it couldnt use WPA as 802.1x wasnt enabled.

How do I enable this ?

Thanks

Gaz
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
You're aware that WPA is weaker than WPA2, right? Please try to get everything over to WPA2, if possible.

That being said, you can create/enable WPA by netsh:

netsh wlan> set profileparameter name=<ProfileName> authentication=wpa encryption=tkip authMode=userOnly
netsh wlan> set profileparameter


If that didn't work, try the "UseOneX=yes" parameter

netsh wlan> export profile name=<ProfileName>

to assist in the future
Distinguished Expert 2018
Commented:
Why use WPA when it's been shown to be flawed and has been replaced with WPA2? It sounds like your network is using a preshared key. Upgrade to WPA2 and get all of the existing systems working on it. Some systems allow you to use WPA2 with both TKIP (for support of older devices) and AES (which is really what you should use).
Distinguished Expert 2018

Commented:
Question answered

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial