Certification error

We just installed a brand new Exchange 2013 server. When we configure Outlook 2010 we get a ceritification error:

- The name on the security certificate is invalid or does not match the name of the site

The Outlook client is being added while it's internally into the domain.

It's not a self signed certificate, it's a brand new comodo one.

For all I know, everything in exchange is set right in the internal and external server settings. Autodiscover is configured and can be found with nslookup. Exchange is up to date with the latest updates.

Did I miss anything?
LVL 1
IT MeetjeslandAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Will SzymkowskiSenior Solution ArchitectCommented:
- The name on the security certificate is invalid or does not match the name of the site

Based on that message above, this is due to your virtual directories not set correctly using the FQDN that is on the certificate.

Make sure that you have your correct URL's for internal and external.

Also run the Test Email Auto Configuration from Outlook and make sure that the Outlook client is getting the correct URL's from the Exchange server.

Will.
0
IT MeetjeslandAuthor Commented:
I  check the virtual directories again, I need to set the internal and external to mail.company.com, right? I have done that. However I just noticed that Autodiscover is set to the local servername and I can not change that. Is that normal? I'll run the outlook check.
0
Will SzymkowskiSenior Solution ArchitectCommented:
Your autodiscover should also point to autodiscover.domain.com. You also need to have split DNS setup and well making sure that you have an A (host) recrod for mail.domain.com and a cname record for autodiscover.domain.com.

Check out my HowTo for this. Also make suer that your have properly enabled the new certificate and assiged it correct services.

http://www.wsit.ca/how-tos/exchange-server-2/configure-split-dns-and-exchange-2013-virtual-directories/

Will.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
IT MeetjeslandAuthor Commented:
That did the trick, thanks!

I added the autodiscover with the command line and I had autodiscover added as an A reccord instead of a CNAME.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.