451 4.4.0 DNS failed exchange 2010

I added a new exchange server and now mail start routing through that server. The email messages are stuck in that server with error 451 4.4.0 DNS query failed.

how do I configure the server not to route mails through this new server and just use the old server to rely email . Its a multirole server
numanmalikAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Will SzymkowskiSenior Solution ArchitectCommented:
I am assuming that you have installed another Exchange Server in the same AD Site? If this is correct Hub Transport Role will automatically work "out of the box" and be highly available without addtioinal configuration. This is by design.

Internal Mail should be routing fine however if you are getting this message when sending external eamil then just remove the new Exchange server from the Send Connector for Outgoing mail. This will force all of the Outgoing mail to go through the old Exchange sever and not the new one.

Will.
0
numanmalikAuthor Commented:
The new server is not mentioned anywhere in the send connector.  There are default receive connector created automatically when you install the server.
0
Md. MojahidCommented:
in the properties of the smarthostdeliveryconnector, Network tab,

try to check "Use the External DNS Lookup settings ont the transport server"

if already checked, try to specify dns servers explicitely

---

as a quick workaround for the time being, adding a line in the hosts table or using the ip addresses associated with the mimecast server in the connector should work
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

numanmalikAuthor Commented:
I've requested that this question be deleted for the following reason:

Issue resolved
0
Will SzymkowskiSenior Solution ArchitectCommented:
Can you please elaborate on what the resolution was?

Will.
0
numanmalikAuthor Commented:
I added the server as authorized mail server to send email outbound in the receive connector. I think it was very basic which I probably forgot.

As soon you bring or install new hub server in a site. Exchange Hub transport Server will be automatically load balanced with in the Active Directory Site. Hub Transport Servers are load balanced in Round robin fashion with in the Site. If you want to Force Exchange Mailbox server to use specific Hub Server you need to make use of SUBMISSIONSERVEROVERRIDELIST

e.g  Set-MailboxServer -Id:MailboxServer1 -SubmissionServerOverrideList: htserver1,htserver2
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Servers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.