SBS 2011 Sharepoint problems

Recently we started getting multiple errors in our event logs, both system and application, related to SharePoint. And coincidently our backups stopped working at the same time.

e have an SBS 2011 server setup using the wizards, nothing special, and we do host our own email using Exchange. We do not use SharePoint however.

We started getting this error in our application logs;

SQL Database 'SharePoint_ConfigurationDatabase' on SQL Server instance ' ServerX\SHAREPOINT' not found. Additional error information from SQL Server is included below.

Cannot open database "SharePoint_ConfigurationDatabase" requested by the login. The login failed. Login failed for user 'Domain\spfarm'.

What is the default password for the user spfarm on an SBS 2011 server? We didn't create or change one, so we are not sure what this would be?

We also get this error in our system logs;

The SharePoint 2010 Timer service terminated unexpectedly. It has done this x time(s). The following corrective action will be taken in 30000 milliseconds; Restart the service.

Everything else seems to be working fine. We would like to correct these errors and get our log files back to be clean again. Any suggestions would be greatly appreciated.
holcomb_frankAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rainer JeschorCommented:
Hi,

the SharePoint accounts are created dynamically with managed Passwords - so you never know them.
Normally SharePoint takes care the the Passwords are updated on a regular base and that they are then synced.

You might try to run the following PowerShell command inside of a "SharePoint Management Shell":
Set-SPManagedAccount -UseExistingPassword -Identity Domain\spfarm

Open in new window


You are not using Company Web?

HTH
Rainer
0
holcomb_frankAuthor Commented:
No they do not use the company web, but it's also not loading..... going to http://companyweb we get the following error.     "Cannot connect to the configuration database"

When I load the Windows Powershell , it loads the SharePoint module already which I was able to confirm. So then trying your suggestion...it ask that I supply values for the following parameters: ExistingPassword:      So this just errors out.  Any other suggestions?
0
Rainer JeschorCommented:
Hm,

did never get this error before.

Could you please try the steps mentioned in the MS blog entry to repair the managed SharePoint accounts?
http://blogs.technet.com/b/sbs/archive/2011/08/17/http-error-503-accessing-company-web-on-sbs-2011-standard.aspx

HTH
Rainer
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

holcomb_frankAuthor Commented:
Rainer,

I tried the suggested steps....  From a shell....  Repair-SPManagedAccountDeployment and I get an error ....

Cannot access the local farm. Verify that the local farm is configured, currently available, and that you have the appropriate permissions to access the database before trying again.
0
Rainer JeschorCommented:
Hi,
have you explicitly started the SharePoint Management Shell with "Run as Administrator"?
0
holcomb_frankAuthor Commented:
Rainer,

Just to be clear..... I start the Windows Powershell , with "Run as Administrator" .... and I can see it load the SharePoint Management Shell commandlet as it loads. And if I try to start or install a SP Management Shell it tells me it's already running. So I'm assuming it is....it takes the commands. And yes to answer your question I'm using " Run as Administrator". If I don't it won't let the SP Management Shell and it doesn't take my commands. This is outside my usual work... so feel free to correct my procedure if I'm incorrect here.
0
Rainer JeschorCommented:
Hi,

no thats right. But most persons which are unfamiliar with SharePoint run PowerShell with an administrative account but not with the extra "Run as Admin" and therefore get errors when executing SharePoint PowerShell commands.
As my SBS 2011 experience is that old, I just try to eliminate issues of this kind :-)

I have to have a look - will take some time until I am at home.

KR
Rainer
0
Cris HannaCommented:
This is a pretty easy fix if the problem is as I suspect.   There is a command that must be run on the SBS server every time you install a sharepoint update

https://social.technet.microsoft.com/Forums/en-us/94c5f178-f020-4d0f-ba7c-11c415d0d862/manually-running-psconfig-is-required-after-installing-sharepoint-foundation-2010-updates?forum=smallbusinessserver

1. Open an Administrative command prompt.
 2. Change directory to C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\BIN
 3. Run PSConfig.exe -cmd upgrade -inplace b2b -force -cmd applicationcontent -install -cmd installfeatures
0
holcomb_frankAuthor Commented:
Chris,

A couple of things first I wanted to share..... no pun intended. I checked the updates and I don't see SP 1 for SharePoint listed as an installed update in control panel. I also checked the updates in the SBS Console.....   SP2 for SharePoint is an available update to install though.

Trying your suggestion - running PSConfig.exe   I get the following.....

Waiting to get a lock to upgrade the farm.

Failed to initialize SharePoint Products upgrade.

An exception of type System.Data.SqlClient.SqqlException was thrown. Additional exception information: Cannot open database "SharePoint_ConfigurationDatabase" requested by the login. The login failed.
Login failed for user 'Domain\Admin'.

Total number of configuration settings run: 1
Total number of successful configuration settings: 0
Total number of unsuccessful configuration settings: 5
Successfully stopped the configuration of SharePoint Products.
Configuration of SharePoint Products failed. Configuration must be performed before you use SharePoint Products. For further details, see the diagnostic log located at ........\Logs\PSCDiagnostics_...........

It didn't work , and the /companyweb is still not working.....

It did stop all the SharePoint services on the server as well as the World Wide Web Publishing Service.... had to go on site to restart the services .
0
Cris HannaCommented:
I suggest that you check out this blog from the SBS product team regarding the sp passwords.   I suspect with the previous instructions provided to you, that passwords are horked up a bit
0
holcomb_frankAuthor Commented:
Chris,

As mentioned previously in this thread..... I did try the suggestion here as well....

"I tried the suggested steps....  From a shell....  Repair-SPManagedAccountDeployment and I get an error ....

 Cannot access the local farm. Verify that the local farm is configured, currently available, and that you have the appropriate permissions to access the database before trying again. "

So while it may indeed be an issue with passwords not syncing or out of whack as it is.... this method is not working to try to resolve it....
0
Cris HannaCommented:
First I would start here
https://technet.microsoft.com/en-us/library/gg697170.aspx   Repair administrator account access to SharePoint Foundation 2010

If that does not help. I would go here https://technet.microsoft.com/en-us/library/gg680310.aspx
Repair SharePoint Foundation 2010
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.