Help with basic vlan configuration in Cisco Packet Tracer

Hello Cisco Experts,

I’m working on teaching myself networking.  I currently do not have any actual Cisco equipment (I’m going to get some switches off ebay when I get some funds), but I do have Cisco Packet Tracer, so I’m using it to work through some labs.  I’m having some trouble wrapping my head around a vlan configuration and I’m not sure if the problem is an actual issue or a Packet Tracer issue.  I have two switches connected back to back via a cross-over cable.  The configuration on each switch is as follows:
 SW1> enable
SW1# config t
SW1(config)# interface vlan 999
SW1(config-if)# ip address 10.99.99.1 255.255.255.248
SW1(config-if)# no shut

SW2> enable
SW2# config t
SW2(config)# interface vlan 999
SW2(config-if)# ip address 10.99.99.2 255.255.255.248
SW2(config-if)# no shut

When I do a show ip interface brief, I see vlan 999 on both switches, but it is in a down down state.  My questions are:
1.      Is this a limitation of Packet or would the vlan interface be down on two real switches?
2.      Is there a way for me to force this vlan interface into an up up state?

Thanks in advance for your help.

Nick
LVL 1
ndalmolin_13Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JustInCaseCommented:
Command interface vlan 999 at least on some version of Packet tracer will not create VLAN 999, so you should use vlan  999 command in global configuration mode.
 
But, not bringing it up is not limitation of Packet tracer, it is how it is in real world.
Way to bring interface VLAN up up is to add port to that VLAN that is in up up state (trunk port with allowed vlan 999 on it can do it in real world, and in Packet tracer), second way to bring vlan 999 up up (is to use no autostate command under interface vlan (not available in Packet tracer)), also access port assigned to VLAN 999 with attached host to it - will bring interface VLAN 999 up (real world and Packet tracer).

So, I guesse you should configure your link between switches with
interface fa0/x               <or gi9/x>
switchport mode trunk
That should bring your interface vlan to up up
:)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ndalmolin_13Author Commented:
That worked.  Thanks for the explaination.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.