How to set permissions on server share for remote access via a VPN

Hi,

I have a Windows 2008R2 machine running as a (development only) IIS webserver in a remote location from the office. The web folder is on the E: drive rather than the OS drive and I can access and make changes using Remote Desktop.

I recently setup a VPN and mapped a drive on my Windows 10 Laptop to the wwwroot folder on the server. The problem is that I'm unable to create or edit files or folders on the mapped drive due to insufficient permissions.

I use an administrator's account to log on to the server using RD and the VPN but the permissions don't seem to flow through to the mapped drive. I need some help in setting the correct permissions on the server's share but I am unsure how to do that.
DavidBurchettAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Muhammad BurhanManager I.T.Commented:
may be administrator doesn't have permissions to edit files in that folder.
for troubleshooting double check the share/NTFS permissions on that folder and add administrator if not exist.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DavidBurchettAuthor Commented:
Hi Muhammad,

The servers admin account has full permissions on the wwwroot folder, I can edit and add files and folders under wwwroot using RD no problem.

It's when I try and do the same thing on my Windows 10 laptop that I get the permission error.

The laptop is connected to the server via VPN, I've mapped a drive letter to the wwwroot share on the server and it shows up in explorer on my laptop, just can't edit anything yet...
Muhammad BurhanManager I.T.Commented:
have you tried with another credentials instead of administrator ?
for troubleshooting please add another user in server and give permissions for Dial-in and share/ntfs then try to connect through new user and see what happens ?
is this workgroup env or domain ?
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

DavidBurchettAuthor Commented:
There is another account I could use but was not listed in the security tab for wwwroot on the server. When I added it and set to full control I got a warning:

"Remotely setting permissions on the folder at the root of a share removes all inherited permissions from the root folder and all subfolders.  To set permissions without removing the inherited permissions, click No and either change the permissions on a child folder or make the change while logged in locally"

I dare not risk making any changes remotely as I have websites and apps that have special permissions (IIS_IUSRS etc) and if I overwrite them my sites will stop functioning.

I did check the dial -in tab for the administrators properties dialog and changed it from "Control access through NPS Network Policy" to "Allow Access" then disconnected the VPN, reconnected and tried again but still unable to edit anything under wwwroot on the mapped drive.

The server is MS 2008 R2 running 5 roles: Application Server, DNS Server, Files Services, Network Policy and Access Services and IIS web server.
Muhammad BurhanManager I.T.Commented:
please don't try any deep procedures remotely on folders or services.
make another folder in another driver and then try the procedures on that folder.
DavidBurchettAuthor Commented:
All fixed...

I made the error of not specifying the administrator's account when sharing the wwwroot folder on the server. It was set to the default of: "Everyone"

Of course, "Everyone" only have Read permissions!

Once I added the admin account in there it was all go.

Many thanks for your help :-)
Muhammad BurhanManager I.T.Commented:
thanks for your response.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.