VM Guest IP Config Problems

Hello.  I have a VM Guest machine that was working but then has somehow lost its IP configuration and I am unable to correct it to get it connected to the network again.  It has worked for 4-5 months, and then started having the issue over the last few days.  Nothing has changed on the machine, to my knowledge.  I have rebooted several times, as well as uninstalled and reinstalled the network adapter.  It still is not pingable, and shows a yellow trouble icon on the network adapter indicator in the service tray.  An IPCONFIG also shows nothing.  Not sure what's wrong.

Ipconfig
Damian_GardnerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
What is the Host application?  If VMware Workstation, you can launch the Network Editor as Administrator and Reset the network configuration.  Have the guest machine OFF when you do this.
0
Kash2nd Line EngineerCommented:
Was this VM in question P2V or created after host initialization ?
Have you tried removing the VNIC and re-adding it.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Make sure you have VMware Tools installed, and make sure you are using the VMXNET3 interface, uf using VMware vSphere (ESXi)
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

Damian_GardnerAuthor Commented:
Sorry for the late reply, gentlemen. let me address each question below:

John: yes, the host app is indeed VMware Workstation Ver 8.  I have gone into the network editor, to reinstall the NIC, but don't think I reset it.  I will check that.  I did do that while the machine was off.  

Kash: the VM was a new machine created from a template, and was never a physical machine.  I have reinstalled the NIC - it started out as a VMXNET3 adapter, and I tried the INTEL just for the heck of it, to no avail.  it is still the Intel adapter, at the moment.

Andrew: I had VMXNET3 initially and have changed to the INTEL adapter, just to see if there was a change.  but no change.  I have also uninstalled and then reinstalle dthe VMWare tools.  still no good.  maybe I shold put it back to the VMXNET3?
0
JohnBusiness Consultant (Owner)Commented:
Yes, make sure machines are OFF before resetting the Network Editor.

Also Workstation 8 is old, so consider upgrading it.
0
Damian_GardnerAuthor Commented:
ok.  how do you "reset" the NIC?
0
JohnBusiness Consultant (Owner)Commented:
Open Network Editor with Run as Administrator and click on Restore Defaults bottom left.

You should restart the computer after doing this.

If you wish to reset the NIC inside the guest machine, you would do this with TCP/IP Reset assuming Windows guest.
0
Damian_GardnerAuthor Commented:
ok..so apparently this is not something that comes up in VSphere Client - only VMware Workstaion?  do I need to download that and install, or just use the Web Client maybe?  or am I missing something.  I cannot locate the Network Editor
0
JohnBusiness Consultant (Owner)Commented:
You said you were using VMware Workstation V8 and Network Editor is in the VMware Program Folder.  If not, you may need to reinstall VMware, or preferably upgrade it as a modern operating system needs a new version anyway.
0
Damian_GardnerAuthor Commented:
right - the VM Version of the guest machine is 8.  I'm assuming that if the machine must be off, then nothing on the guest machine can be accessed, and that this must be an editor that I access via either the Vcenter VSphere Client, or the Web Client.  I have not tried the Web Cliewnt yet, as I'm not used to it.  but I can , if that's worth the effort.  I looked at upgrading to Ver 10, but it says its a permanent move, and that the guest will no longer be manageable from the VSphere Client after that, and I have a couple other admins here who I need to talk to before I do that.  I've never needed to go into any "VMware Program Folder" so I'll look this up and see what you mean by that.  perhaps its something on the "Workstation" app, which I'm not using...
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
are you using VMware Workstation or VMware vSphere ?

there are mixed messaeges here in your post ?

Install VMware Tools, these are required, and add a VMXNET3 interface, do not use the e1000 legacy interface.

Correct, if the VM is off, nothing can be acccessed.

Do not change it to a v10 machine at present, this will not help the current situation and issue.
0
JohnBusiness Consultant (Owner)Commented:
You said earlier "yes, the host app is indeed VMware Workstation Ver 8"  If so, Vsphere is not involved.

So you really need to clarify the following:
1. What is the HOST operating system.
2. What VMware are you using?  Workstation or ESX?
3. What is the guest OS.?
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
I think he may mean, the virtual machine hardware version is 8!

because he also refers to VMXNET3 interface, and now the vSphere Client, and Web Client...

all of which are VMware vSphere...
0
JohnBusiness Consultant (Owner)Commented:
It certainly is confusing above, but within a guest TCP/IP reset could help
0
Damian_GardnerAuthor Commented:
my fault gentlemen - I did mean the VMWare VERSION is 8.  yes this is VSphere ESXi 6.0, and I'm using the Client to log in to VCenter server to manage them.  I didn't realize there's another application called "Workstation", and thought you were referring to the version of the VM guest.  sorry.  

Clarification:

HOSTs are ESXi 6.0
VM guests are Ver 8
Guest OS in this case is Windows 2012 R2
0
Damian_GardnerAuthor Commented:
BTW - VMware Tools are installed and the NIC is back to VMXNET3. same status, however, after a reboot
0
JohnBusiness Consultant (Owner)Commented:
So try resetting TCP/IP is the Server Guest and see if that restores network connectivity.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Damian_GardnerAuthor Commented:
Well...nothing is helping, gentlemen, so I've opened a case with VMWare.  will let you know what they find.
0
Damian_GardnerAuthor Commented:
Sorry guys - I forgot to report back.  VMWare was not able to figure it out and recommended starting with a fresh VM, and restoring the applications and data to it.  I did that and the problem went away.  Must have been a glitch.  Thanks for your help.
0
JohnBusiness Consultant (Owner)Commented:
Thanks for the update and I was happy to help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.