ESXi Host Evaluation License Expired

I have a lab with one host (4.1) and 4 virtual servers.  The VCenter Server is one of those servers.  I have a Sharepoint, DC and Exchange server in the lab.  I have purchased a valid license, but forgot to install it prior to the evaluation server license expiration.  When I logged int this morning using a client, the VM's were running, but the Host showed Disconnected.

I went into Administration and loaded the license and closed the administration tab.  I then tried to connect the host, but it said the evaluation license was expired.  So I went back in and the new license showed loaded.  So I powered off all the VM's and the host.  Powered the hose back on and it still showed the eval license expired.

So I went into the configuration tab and went to license features.  I clicked on the edit link on the far right, but that times out.

How do I get the license installed and the lab back up and running.
sfletcher1959VPAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
are you connecting directly to the ESXi server using the vSphere Client ?
sfletcher1959VPAuthor Commented:
I am connecting using a Vsphere client on another server and pointing to the IP address of the ESXi Host.

It does connect, but will not let me edit the license features and I don't see another way to add the license.Host snapshotHost 1 snapshot
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
I would try and restart the server, or restart network management agents.

and then.....I've got a few more ideas....
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

sfletcher1959VPAuthor Commented:
I have restarted multiple times.  I believe this restarts the management agents.
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
yes it does. seems very odd.

okay, you could try to remove the existing license.

this is *not supported*

logon via the console or remotely via SSH

cd /etc/vmware
rm vmware.lic
rm license.cfg

you make want to cp the files and make backups!

restart server and try again.
sfletcher1959VPAuthor Commented:
This server is remote to me.  I had already thought about this, but it will have to wait for Monday when I can get in front of the box.  Thanks so much Andrew.  Hope you have a great weekend.  Cheers
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
no probs.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sfletcher1959VPAuthor Commented:
Andrew that worked perfectly.  I was able to open on a new evaluation license and then apply the new license without any issues.  Up and running.  Thanks.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Virtualization

From novice to tech pro — start learning today.