Mitel 5000 - Adding a POE switch - Netgear & Cisco switches

jkimzlg
jkimzlg used Ask the Experts™
on
We have a Mitel 5000 system and use VOip/POE.  We have two working Netgear gs748tp 48-port gigabit POE switches that all our phones plug into.  We are trying to add a Cisco SG500-52p POE switch to add more phones.  When we plug our phones into this Cisco switch it does power on but it says contacting DHCP server.  When I plug a laptop into the Cisco switch I get an ip address, I have Internet and I can ping across all our networks (192 and 172 networks).

On one of our Netgear switches, ports 1 & 2 are on VLAN 10 (192.168.170.0 network).  Port 1 connects to our Mitel phone system and Port 2 connects to our Sonicwall firewall.  The rest of the ports are on VLAN 1 (172.16.202.0 network).    

I haven't configured anything on my Cisco switch yet.  What do I need to do? Why can't my Mitel phone get an ip address?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Distinguished Expert 2018

Commented:
it does power on but it says contacting DHCP server.
I guess it does not contacting DHCP server.
If I am right turn of STP on phone port(s) (or for any edge device) using
(config)# interface <type>0/x
(config-if)# switchport mode access     <----- set port to access mode
(config-if)# spanning-tree portfast        <----- disables STP on port

Most likely phone sends DHCP request while port is going through listening and learning phase.
I guess you plugged switch in access ports in VLAN 10 (on one of other switches) otherwise you need to create trunk from one of switches to Cisco switch and set ports for phones to VLAN 10 (if that's your phone VLAN). By default like always all ports are untagged and in VLAN 1. So if you attach switch to access port of your phone VLAN and portfast is configured everything should work.

Author

Commented:
thanks for the response.  The only vlan 10 ports I know of are on ports 1 & 2 of my netgear device.  I actually plugged in one of my phones into a Vlan 1 port on the cisco switch and it doesn't work (says contacting dhcp server).  But if i plug it into the Netgear switch on a vlan 1 port the phone works fine.  I haven't configured the cisco switch at all so everything is on vlan 1.  I'm guessing I have to start by creating a trunk.  Or do you think I just have to turn off STP?
Distinguished Expert 2018

Commented:
Then plug Cisco switch in VLAN 1 port and set portfast on phone ports on switch. In that case phone should get response from DHCP server before it stops waiting for DHCP response.

Contacting DHCP server most likely means - I sent DHCP discovery message - waiting for response, and phone is not sending another one although the first discovery message did not reach DHCP server. If I am not wrong about that, portfast should allow DHCP discovery message to be received by DHCP server and phone should be able to get data from DHCP server. So, you could also need to set portfast on link to other switch. If my assumption is wrong that will not help ... :)
Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

Distinguished Expert 2018

Commented:
I searched around for solutions, to check if there are some issues...
I think that reading "Deploying..." article can point you in right direction, since I am not familiar with your current configuration, "Setting ..." article can be workaround. :)
Deploying Mitel IP Phones in a VLAN/DHCP Environment .
Setting Mitel phone in teleworker mode
You could also sniff packets with Wireshark to try to identify issue (packets from working phones and non working phones to check the difference).
Commented:
Thanks for your help.

We now can use both the Netgear and the Cisco switches for the phones.  I didn't need to disable STP (in fact cisco doesn't recommend this).  I pretty much just had understand the following:    

Untagged -> Only a PC understands this language
Tagged -> Only phones understand this
1UP -> stands for VLAN 1 Untagged Primary (this is how the uplink port gets untagged traffic, then you add Vlan 10 and Tag it).

And I just needed to configure two areas within the Cisco switch (attached pics):
capture.png
capture2.png
Distinguished Expert 2018

Commented:
I didn't need to disable STP (in fact cisco doesn't recommend this).
Cisco don't recommend this for entire switch, but for interfaces for end devices - PC, Phone etc (that's how I configured it - on phone port). The reason is STP  topology change notification.
By default aging time on switches is 300 sec, and when switch receives TCN all bridges become aware of the event and reduce their aging time to 15 seconds. This causes many unnecessary broadcasts since switch forget where are MAC addresses that were quiet in those 15 seconds...
And down in the same article Avoid TCN Generation with the portfast Command ...
:)
Untagged -> Everyone network device understand this :)
Tagged -> Switches, Routers, Phones, Servers and other devices can understand this

Author

Commented:
I was had to contact Cisco for help and they were able to get me going.  I have provided as much info as I can about this issue in case someone else is having the same problem.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial