Changing Path to PHP

Hello,

     I am using Windows Pro 7, Web Matrix 3, IIS Express 8. I have installed PHP v5.5 but when I execute:
 phpinfo(); 

Open in new window


 it shows that the installed version is still PHP 5.3 !  I have selected PHPv5.5 in Web Matrix but I don't think it is recognizing it because driver errors.
I have attached a screen snap of the information.
How  and where do  I change this?
Thank you in advance....
PHP-Info.JPG
OverthereAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Tom ChadaraviciusSenior DeveloperCommented:
The php.ini nor its location will change the version of the PHP. It is the dll that runs PHP compiler and sets the version.
https://technet.microsoft.com/en-us/library/hh994592.aspx
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CANADIANCommented:
Overthere

you can try 2 ways let

Windows + R
cmd + enter

c:\>php --ini
or
c:\>php -i

i recommend download and install EasyPhp after installed you can have version right you choise or need it !

Best Regard

Canadian
0
OverthereAuthor Commented:
Here is what worked:
The article was very helpful. I followed the instructions but it still did not resolve the problem. THEN, I realize while looking at the phpinfo printout, where it was "loading" the php.ini! It was loading from C:\Program Files (x86)\IIS Express\PHP\V.5.3. That being so I checked the folder.
And there was my folder for PHP 5.3 and 5.5. So, I stopped IIS Express, I renamed the PHP 5.3, made changes to the php.ini file in the folder PHP 5.5, restarted IIS Express and viola! I have version 5.
To ensure the results, I did a reboot of my computer, and tested each website that originally used
PHP 5.3. All of them worked correctly. I am using Web Matrix, so all I had to do was select the version of PHP 5.5  under the sites settings. And all is well now. Each site is working correctly.
I am splitting the points as I feel both of you deserve it. If this is not agreeable, please let me know.
I thank you both for responding. :)
1
OverthereAuthor Commented:
Got me going in the right direction! And have another good resource for php.
1
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
PHP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.