WSUS 3: Cannot connect to MSSQL database using Management Studio

Hi All,

Our WSUS 3 server running on Server 2008 R2 with a local MSSQL instance.

I'm unable to view All Updates.  So I thought running the WSUS re-index script would be a good idea.

https://gallery.technet.microsoft.com/scriptcenter/6f8cde49-5c52-4abd-9820-f1d270ddea61

However my account, which is a member of the WSUS Administrators, Domain Administrators and (local) Administrators group is unable to connect to the database

The server has MSSQL Management Studio locally installed.

This is the error message

MSSQL-Error.PNG
LVL 2
detox1978Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

OriNetworksCommented:
You probably have to enable tcpip for the sql instance

https://msdn.microsoft.com/en-us/library/ms191294(v=sql.100).aspx
detox1978Author Commented:
I've enabled TCP/IP, but get the same error.  Studio Manager is on the same server as the instance
Jerry_JusticeCommented:
1 - Have you connected with these credentials before?
It is not unusual for administrators to be left out of the list of logins.

2 - Are you sure the service is running?  Have you checked services?

3 - Have you tried connecting using the "sa" login?  (Assuming it is mixed mode security)
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

detox1978Author Commented:
1.  No

2.  yeah, they are running.  It's a WSUS server that I can use and access, it just keeps crashing.

3.  WSUS doesn't have an SA account
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
You can't connect to Microsoft Internal Database (MICROSOFT#SSEE) with TCP/IP, only with Named Pipes.
Pay attention to the note in the script link telling you need to use
sqlcmd -S np:\\.\pipe\MSSQL$MICROSOFT##SSEE\sql\query –i <scriptLocation>\WsusDBMaintenance.sql

Open in new window

Also make sure to stop WSUS, as you can only connect with one session at a time to Windows Internal Database, IIRC.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
detox1978Author Commented:
Sorted it.  Withint SQL Management Studio I had to connect to

\\.\pipe\MSSQL$MICROSOFT##SSEE\sql\query

NOT

SERVER\MICROSOFT##SSEE
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2008

From novice to tech pro — start learning today.