XP Pro desktop dropping itnernet connection

Hello. I have  a Dell Inspiron 530 running XP Pro that keeps dropping my internet connection.

We have a D-Link DSL-520B modem connected to a D-Link DIR-632 router.

The router is connected to my computer, my boyfriend's computer (a Dell XPS 410 running XP Home), two other desktop computers, a cell hotspot, a laptop, and three printers.

My computer is the only one dropping connections, sometimes every couple of weeks and sometimes (like today) several times a day. Very frustrating. Any ideas what could be causing this?
Elizabeth Bakerexe asstAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Michael-BestCommented:
Go to Dell site download and install any updated drivers.
Check the power saving settings, the network interface card may be going to sleep.
FOXActive Directory/Exchange EngineerCommented:
go to the dell site and check to see if you are using the most recent drivers for your wireless card and your local nic as well

http://www.dell.com/support/home/us/en/19/product-support/product/inspiron-530/drivers
Michael-BestCommented:
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

FOXActive Directory/Exchange EngineerCommented:
Baker,
Just as Michael has stated as well, check your power management settings on the nic.
Control Panel>network>right-click your Lan connection>properties>click the configure tab>power management tab
UNTICK "Allow computer to turn off.........
nicpower.JPG
Elizabeth Bakerexe asstAuthor Commented:
Okay, I looked at Michael-Best's link. The driver version listed there (v.9.8.20.0) for my Intel card seemed older than the one I currently have (v.9.16.10.0). Also I tried to update the driver from the Lan connection properties and it said I have the most current driver.

I checked the power saving settings as instructed by Foxluv and unticked "Allower computer to turn off...", but I don't understand how this would help, as I'm on AC and there should always be power.
Michael-BestCommented:
The "Allow computer to turn off this device to save power" is referring to turn off the network interface card device (this device controls your internet connection), and is NOT referring to turn of the computer.
 
Also it was I that posted "Check the power saving settings, the network interface card may be going to sleep."

Foxluv posted a guide to do this, while I was typing the method, so did not repeat the same information.

Hope this helps and your issue has been resolved.

Regards,
Michael
Elizabeth Bakerexe asstAuthor Commented:
Thanks, Michael. I don't know how long I should wait to see if this solves the problem or not. Obviously, if it occurs again in the next couple of days, I'll repost. If not, I'll probably wait a couple of weeks or so and then close the question. Is this something that happens with XP Pro and not XP Home, do you know?
Michael-BestCommented:
All MS OS have the option "Allow computer to turn off this device to save power"
Some PCs do turn off the NIC device to save power, some do not.
Something to do with PC makers design in sleep settings?
Never did find out why ... maybe an EE post will answer that?
Always used the un-check "Allow computer to turn off this device to save power" as the solution.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Elizabeth Bakerexe asstAuthor Commented:
Thanks so much for your help. If this doesn't work, I'll open a new question. I don't want to keep this one open indefinitely, as I tend to forget them after a while if there are no further problems to remind me.
Michael-BestCommented:
Glad to help.
If do you have a new question, then please post the link to it here, to get my attention.

Regards,
Michael
Elizabeth Bakerexe asstAuthor Commented:
Okay, thanks, Michael.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Desktops

From novice to tech pro — start learning today.