Windows 7 log off user when computer is locked

Hi Experts,

I am facing this strange issue where Windows 7 log off the connected users when the computer is locked.

Basically if i log in and then lock the computer and come back after 2 or 3 days to log back in my account is no longer locked, I have to login fresh and all the settings again gets applied.  Any running programs are also closed.

I have try searching everyone but I cant seem to find a solution.

I have change power settings to never put the computer to sleep / no hibernation /  high performance
I have also unchecked the NIC power setting to  "not turn off this devices to save power"

Your help is appreciate .

thanks,
tech-gineerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

steve_fernandesCommented:
Check to see if there is a scheduled task that is performing a shutdown command with the reboot option somewhere,

shutdown -r

You can also open a command prompt and then type in:

syteminfo |findstr "Up Time"


This will give you the last time the system was rebooted. It might give you some insight as to if the machine is being restarted etc. From there it will be a process to troubleshoot as to why this is happening, i.e either script, hardware issue causing a restart or whatever voodoo magic is happening.

Just a train of thought. Good luck.
tmoore1962Commented:
Is the system on a domain?  If so then the admin probably has connection time limits being enforced i.e. login times are configured for say 8-5 for example

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Zac HarrisSystems Administrator Commented:
Hello

When you lock the computer, does the screensaver ever start? If so, make sure you go into the settings for the screensaver and uncheck the box beside on resume display logon screen. If you don't have the screensaver enabled, please let me know and in the mean time, I will continue to work with my system to see if I can replicate the issue.
Active Protection takes the fight to cryptojacking

While there were several headline-grabbing ransomware attacks during in 2017, another big threat started appearing at the same time that didn’t get the same coverage – illicit cryptomining.

Steven CarnahanNetwork ManagerCommented:
Along the lines of the scheduled task option you may also want to look to see how MS updates are handled.  If set to automatically download and install you may want to change it to download but let you decide when to install.
tech-gineerAuthor Commented:
Hi to All,

Tmorre1962 - The computer is in a domain and has enable the connection time limit.  I believe this might be the problem because I tend to login via RDP.

Below are the 2 settings that apply.

--Set time limit for disconnected sessions  ---- Enabled ---- 1 day
--Set Time limit for active but idle Remote Desktop services --  enable --- 5 days

Now,  How can I block this setting to not apply to this specific computer?   I tried changing the computer local group policy but is not taking effect.

Zac - I don not have the screen saver enable.   It seems to me that my issue is with the connection time limit.

thanks in advance Experts .
steve_fernandesCommented:
You could kindly ask the domain admin for a user exception policy gpo for those two settings for your username. Chances are they will ask for a business case. Or if you are the domain admin, just ensure you don't violate company security policy.


Gpos overwrite a lot of the local security policies by default every 15 minutes. It's what allows for administrative control and a manger environment in the enterprise.

Other options would be to have gpo exception container policy created.
Steven CarnahanNetwork ManagerCommented:
Were those settings done in Terminal Services Configuration?  Those will apply to everyone that connects.  If you want to apply based on user then you need to use the User or Computer Configuration GPO.

MS explanation of these policies: https://technet.microsoft.com/en-us/library/cc753112(v=ws.10).aspx
LeeTutorretiredCommented:
I've requested that this question be deleted for the following reason:

Not enough information to confirm an answer.
tech-gineerAuthor Commented:
It was a session timer GPO policy preventing the OS to keep me logged.

Thanks,
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.