The server denied the connection - RDP

Hello,

We have a Windows 2003 server running Exchange 2003.  We cannot RDP into this server anymore for some unknown weird reason.  It worked just fine up until a few days ago.  It tells us "The server denied the connection."  I have tried every fix I have found on the net for this and nothing has worked so far.  I've checked all of the permissions, group policy, local policy, seemingly everything.  We have rebooted the server.  Does any one else have any ideas?  It is a VM.

Thanks,
Mike
cheesebugahAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RantCanSr. Systems AdministratorCommented:
Is the VM syncing time with the host? Can you log into it via the console?
0
cheesebugahAuthor Commented:
Yes, I can log into it via the Vsphere Client console.
0
RantCanSr. Systems AdministratorCommented:
What about the time syncing?
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

cheesebugahAuthor Commented:
The time is fine.
0
MPCP-MattCommented:
Try turning off the firewall, as it could be blocking it. Enable RDP for all users / groups (terminal services users, or something to that effect). Also, try to RDP to the machine using loopback (RDP to 127.0.0.1) as Administrator.

You can also check to make sure AntiVirus isn't blocking it (turn it off and try to RDP).

Lastly, open up regedit and find this key: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber

Which port is it listening on? Could have changed.

Please mark this as answered if any of this resolved your issue!!
0
cheesebugahAuthor Commented:
Can you please explain how to RDP using loopback?  The firewall is off.  AV is off. The registry key is set correctly.
0
cheesebugahAuthor Commented:
When I go to Remote Desktop Users it says:

Domain\me already has access?  What the heck is going on here?  This totally has me baffled.
0
cheesebugahAuthor Commented:
I just saw a solution on the net that said to go into Terminal Services Configuration and right click on the RDP-Tcp connection and change the network adapter to the actual NIC running on the machine.  I did this and tried RDP again.  It no longer says "The server denied the connection," but it does say "cannot establish a connection."  Is this progress...I don't know?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cheesebugahAuthor Commented:
I tried restarting the Terminal Services service, but it is grayed out now?  Odd???
0
MPCP-MattCommented:
Sorry! Haven't been able to check back. For loopback rdp to the address 127.0.0.1 - this tells the machine to RDP to itself. Do this while logged in locally to the terminal server. I will look into what you have posted since my last comment
0
cheesebugahAuthor Commented:
I believe the fix was changing the network adapter in Terminal Services Configuration on the server and then rebooting.

Thanks,
Mike
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.