HttpWebRequest and SHA256

Hello everyone, it's been a long time since I've had to ask for help, but I'm there again. I have an app that connects to a remote web service via SOAP. It's been working great until the host changed from SHA1 to SHA2. HttpWebRequest no longer works. and from what I understand it won't support SHA2. Can anyone point me in the right direction please?
Thanks.
Floyd ShadwickInternal DeveloperAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

btanExec ConsultantCommented:
If the ssl cert is sha2 and tls exchange highest cipher include sha2 then this should still be able to work..have to check if the tls.exchange traffic has what speific ssl tls error...the server os should have these support
0
Jian An LimSolutions ArchitectCommented:
There is 2 type of SHA2

one  is SHA2 with SHA2ROOT and another one is SHA2 with SHA1ROOT

SHA2ROOT offers highest protection but it do not co-existence well with other application

FOr example, Microsoft Exchange won't take SHA2 with SHA2root (baiscally it has CNG component in it)

It will best to use a SHA2 with SHA1root cert, and thats usually will fix the issues.

ask your SSL vendor, they usually can tell you how it looks like
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
btanExec ConsultantCommented:
Yap sha1 root and sha2 for site also common for 3rd party CA and it worked too.
0
Floyd ShadwickInternal DeveloperAuthor Commented:
As it turned out, the problem was mostly in trying to load the certificate from the certificate store. Changing the program to load it directly from the PFX file solved that. We got the vendor to reissue the certificate as SHA1RSA though. I'll have to try it with the SHA2 also. Thanks all.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Visual Basic.NET

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.