help with ReWrite that is not working :( .htaccess

Hi experts,

Some help please:

I have a podcast I have updated the URL on, I am trying to put a 301 redirect rule in place, but I cannot figure out how to make it work.

I want
http://www.auspiciousincubator.com.au/HotTipTuesday/feed/hottiptuesdaypodcast 
to redirect to
http://www.auspiciousincubator.com.au/HotTipTuesday/feed/podcast

I have tried in the .htaccess file in /HotTipTuesday folder (as is base of Wordpress install)
RewriteRule ^hottiptuesdaypodcast http://www.auspiciousincubator.com.au/HotTipTuesday/feed/podcast
RewriteRule ^.hottiptuesdaypodcast. http://www.auspiciousincubator.com.au/HotTipTuesday/feed/podcast
RewriteRule ^hottiptuesdaypodcast? http://www.auspiciousincubator.com.au/HotTipTuesday/feed/podcast
RewriteRule ^.hottiptuesdaypodcast.? http://www.auspiciousincubator.com.au/HotTipTuesday/feed/podcast
RewriteRule ^/feed/hottiptuesdaypodcast http://www.auspiciousincubator.com.au/HotTipTuesday/feed/podcast
RewriteRule ^/feed/hottiptuesdaypodcast? http://www.auspiciousincubator.com.au/HotTipTuesday/feed/podcast
RewriteRule ^feed/hottiptuesdaypodcast http://www.auspiciousincubator.com.au/HotTipTuesday/feed/podcast
RewriteRule ^feed/hottiptuesdaypodcast? http://www.auspiciousincubator.com.au/HotTipTuesday/feed/podcast

Open in new window


I have also tried in the .htaccess file in the root
RewriteRule ^HotTipTuesday/feed/hottiptuesdaypodcast http://www.auspiciousincubator.com.au/HotTipTuesday/feed/podcast
RewriteRule ^/HotTipTuesday/feed/hottiptuesdaypodcast http://www.auspiciousincubator.com.au/HotTipTuesday/feed/podcast
RewriteRule ^/HotTipTuesday/feed/hottiptuesdaypodcast http://www.auspiciousincubator.com.au/HotTipTuesday/feed/podcast?

Open in new window


I also tried adding a $ to the end, but I cannot seem to get it to work.
Ideas? some test the .htaccess is working? Permalinks in Wordpress are working....?

Current contents of .htaccess
Options All -Indexes

# Block the include-only files
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /HotTipTuesday/
RewriteRule ^wp-admin/includes/ - [F,L]
RewriteRule !^wp-includes/ - [S=3]
RewriteRule ^wp-includes/[^/]+\.php$ - [F,L]
RewriteRule ^wp-includes/js/tinymce/langs/.+\.php - [F,L]
RewriteRule ^wp-includes/theme-compat/ - [F,L]
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /HotTipTuesday/index.php [L]
RewriteRule ^hottiptuesdaypodcast http://www.auspiciousincubator.com.au/HotTipTuesday/feed/podcast [L,R=301]
</IfModule>

Open in new window


Your help would be much appreciated :)
LVL 1
Craig LambieAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Steve BinkCommented:
Two notes;

1) RewriteRule and RewriteCond are case-sensitive by default.  The samples you provided in your question do not appear to maintain a consistent approach to case sensitivity.  This can be resolved by a) correcting the case in the rule, or b) using the [NC] flag where appropriate.

2) RewriteRule directives are processed in the same order as listed in the file.  This means that your page not found is triggering the redirect to /HotTipTuesday/index.php.  Place your desired redirection in front of that rule and its associated conditions.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Craig LambieAuthor Commented:
Thanks Steve, I added NC flag and it appears to work with this rule

RewriteRule ^feed/hottiptuesdaypodcast http://www.auspiciousincubator.com.au/HotTipTuesday/feed/podcast [NC,L,R=301]

Open in new window


Full .htaccess
Options All -Indexes

# Block the include-only files
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /HotTipTuesday/
RewriteRule ^feed/hottiptuesdaypodcast http://www.auspiciousincubator.com.au/HotTipTuesday/feed/podcast [NC,L,R=301]
RewriteRule ^wp-admin/includes/ - [F,L]
RewriteRule !^wp-includes/ - [S=3]
RewriteRule ^wp-includes/[^/]+\.php$ - [F,L]
RewriteRule ^wp-includes/js/tinymce/langs/.+\.php - [F,L]
RewriteRule ^wp-includes/theme-compat/ - [F,L]
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /HotTipTuesday/index.php [NC,L]
</IfModule>

Open in new window


Thanks
0
Steve BinkCommented:
Did you need any other information?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Craig LambieAuthor Commented:
nope, that worked, thanks :)
0
Steve BinkCommented:
Then why the "B" grade?
0
Craig LambieAuthor Commented:
honestly an A grade would have been instructions on how to exactly do it.

eg.
1. Move the Rewrite rule to the 7th line of .htaccess and add NC like this:
RewriteRule ^hottiptuesdaypodcast http://www.auspiciousincubator.com.au/HotTipTuesday/feed/podcast [NC,L,R=301]

Open in new window


Mind I would of come back to you as that didn't work, and I had to add "feed/" at the start of the line to make it work still.

I thought that fair enough?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.