dll no longer works in IE

I have a dll on IIS that is served in a web page like so:
<object id="mycrtl" classid="http://server/mydll#mydll.control"></object>.  
it works on iis4 but not iis6.
any help appreciated.
dhenderson12Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BembiCEOCommented:
A very generic question. Have you written he DLL yourself? Or can you make any statement if the DLL is compatible to IIS6?
Is the DLL correctly registered in Windows (as you access a method in the DLL). You may try to register the DLL again with....

regsvr32 <pathToDLL>
0
dhenderson12Author Commented:
sorry for the delay.  the dll is a C# assembly at .net version 3.5.  how can I tell if it's compatible with iis7? (my original question is wrong:  it works in iis6, not iis7).  I have the web app pool set to version 2.0 like the other site that works (iis6).  it is served from iis, so it's not part of the gac.  also, when the web page is loaded, it just flashes up then disappears.

yes, we wrote the dll serveral years ago.  it has the comm visible check box checked.  kinda stumped where to go from here.
0
BembiCEOCommented:
So, f it worked in the older version, but doesn't work in the newer version, I would not expect a compatibility problem with the exception, that you call something in the DLL what doesn't exist anymore on IIS 7. There where some changes. I don't have a IIS 6 machine anymore.
What is about the framework? I would expect, that 3.5 framework has to be present on the IIS 7 machine...
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

dhenderson12Author Commented:
actually, the dll is compiled at .net 3.5, but the working iis6 app pool is set to 2.0.
0
BembiCEOCommented:
If it worked before it should not be the issue, What is referenced in IIS is ASP.NET. So .Net version has mostly to do with the .NET Framework what is installed onto the machine, and at the end it depends, what you have referenced in the code.

It is just a try to set the ASP.Net in IIS to 4.0 in the corresponding app pool to see if it makes a difference. But .Net framework 3.5 should be installed on the new machine,

So have also a look on the old machine, which frameworks are there and make sure they all exist on the new one.

Have you checked the log (IIS and event log if you see something there?
0
dhenderson12Author Commented:
here's what I have found:
1.  the dll was built with .net 3.5
2.  the iis server app pool is at 2.0
3.  nothing in the log to indicate a problem.
0
BembiCEOCommented:
1.) the version in VS is not necessarily relevant, more important is what you have referenced.
2.) This as ASP.NET, nit the framework. As it worked before, I would assume you used ASP.2
3.) OK.

Have you checked the framework version, what is installed on the new machine? Do you have the same frameworks installed as your see on the old machine? So if you see 2.0 and 3.5 on the old machine, make sure you have both also on the new machine (should be if 3.5 is installed).

Note that - dependent from the OS - the older framework may be installed with the OS and the newer ones are installed on top.

You may also check the setting like HTTP activation etc, so the sub properties (server manager - roles and features). An installed framework does not necessarily mean, the IIS is allowed to use it. If a framework is installed vie roles and features, have a look inside what is allowed and what not.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dhenderson12Author Commented:
the problem was setting the caspol using the correct .net framework ... had to use 2.0 and not 4.0.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.