Sony VAIO duo, Model # SVD11213CXB saying "Operating System not found".

I'm troubleshooting a friends computer.  
It is a Sony VAIO duo, Model # SVD11213CXB.  It is saying "Operating System not found".
I have tried doing a refresh, restore, changing the UEFI to Legacy, and back. It keep coming back to Operating System not found.  
It has Window 8.1 on it.    
I'm having a hard time getting it back to the UEFI mode also even after I change it back.  
When it finally goes back to UEFI mode, I have the option to take to do a DOS prompt.  
When I do, I see the OS is on the X: drive and not the C: drive.

Before the OS not found, it was saying cannot boot to drive, drive is locked.
I ran the check disk and after it finished it said Operating System not found.

Has anyone came across this and what did you do to get it go boot to the OS.
Skygod68Sr. Systems AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

☠ MASQ ☠Commented:
Going to assume that it was fine earlier and this has only happened since users have intentionally changed settings in the UEFI.  If it was happening prior to the UEFI changes it could be a corrupt partition.

Are you certain you have the Vaio back in UEFI?  Do you have Secure Boot enabled in the UEFI settings?

When you boot into the Windows Recovery Environment (WinRE) it loads a RAM disk environment to run the operating system which defaults to Drive C: Finding your Windows installation appearing as Drive X: at this point is normal.

It sounds like you have a setting wrong in the UEFI (or UEFI is not enabled) as a security measure the UEFI will only boot to the authorized Windows boot image (EFI\Microsoft\Boot\BOOTMGFW.EFI) when it is enabled.  In the UEFI boot sequence options you should see an entry for "Sony" or "Microsoft" pointing at BOOTMGFW.EFI.  If there isn't one you can recreate an entry and browse to the .EFI path

When you disabled UEFI the path to that image may have been removed
0
rindiCommented:
Boot the PC to the UBCD, and run the HD manufacturer's diagnostic utility. If it tells you there are errors, replace the disk with a new one and use the factory recovery USB stick you made when you got the PC to restore it to factory defaults, or just restore an image from your backups. If for some obscure reason you have lost the factory restore USB stick AND your backups, or they no longer work, order a recovery USB stick from Sony:

http://mirror.sysadminguide.net/ubcd/ubcd535.iso

If the diagnostic tells you the disk is fine, either do a factory reset from the recovery partition (how this is done should be shown somewhere in the PC's manual, or on Sony's web-site), or directly restore a backup image you made.

IF your PC uses an SSD rather than an HD, the diagnostic won't be on the UBCD. You will then have to remove it from the PC and connect it to another PC as a 2nd disk, download the diagnostic tool for the SSD from the manufacturer's site, and run it from there.
0
noxchoGlobal Support CoordinatorCommented:
You need to boot the machine from a Rescue Kit Free: http://www.paragon-software.com/home/rk-free/download.html
Create a WinPE based boot media with it and start the machine from this CD or USB stick. After that go to Boot Corrector and search for Windows installation to correct. Once found update the partition boot record and fix the boot. Try to boot after it.
Note, when you do this the Secure Boot must be disabled. The UEFI mode must be enabled.
Also you can check in commandline which partitions at all you have on the drive and if they have data (through File Transfer Wizard of Rescue Kit).
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Skygod68Sr. Systems AdministratorAuthor Commented:
☠ MASQ ☠,

  The laptop belongs to a 65 year old woman.  She said she has not done anything to it.  The screen I'm on currently,
If I click exit and continue, it will just keep taking me back to that screen.

If I select refresh my PC, it says, The drive where Windows is installed is locked.  Unlock the drive and try again.

When I click advance options and select Restore Point, there are no restore points created.

If I select System Image Recovery, it says no system images are on this computer.

I tried Startup Settings but to no avail.

I tried Startup Repair and it says Repairing disk errors.  This might take over an hours to complete.  At the end of it, it says Operating System not found.

I can get to the DOS prompt and I see an OS is there.
20151111_104043.jpg
0
Skygod68Sr. Systems AdministratorAuthor Commented:
rindi

The laptop is running an SSD 128 gig.  I called up the friend and he is asking his mom if she has the recovery disk.
0
rindiCommented:
Make sure the disk controller in the BIOS is set to AHCI mode or similar. Don't use compatibility, IDE or similar modes.

Since it is an SSD, run the SSD manufacturer's diagnostic, if necessary on another PC, and make sure it's firmware is up-to-date.
0
Skygod68Sr. Systems AdministratorAuthor Commented:
rindi,

Here is screenshots of the BIOS

20151111_145849.jpg20151111_145858.jpg20151111_145908.jpg20151111_145914.jpg20151111_145924.jpg
0
☠ MASQ ☠Commented:
Thanks Skygod68, these screenshots are really helpful.
In the boot menu change Boot mode UEFI to Legacy and External Device to Enabled
Got to Exit > Save changes and restart
0
Skygod68Sr. Systems AdministratorAuthor Commented:
I did that already and it did not work.  I watched that on a YouTube video but no joy.  I will try again.... Nope, comes back up to Operating System not found.
0
☠ MASQ ☠Commented:
And you've already tried Get Defaults in the Exit menu?
0
Skygod68Sr. Systems AdministratorAuthor Commented:
I think I figured it out.   The last couple time I went into the BIOS, the HD was not show there.  I rebooted 5-6 times and the HD would reappear in the BIOS.  Upon the next reboot, I went into the BIOS and the HD was missing again.  I think the SSD HD is toast.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rindiCommented:
I would run the SSD's diagnostic on another PC. Also, some SSD's have a little smaller dimensions when compared to normal disks, which can make the contacts wobble. Sometimes you can make them fit better by using some paper in between to close the gap.
0
☠ MASQ ☠Commented:
No problem, you have the advantage of being on site. Accepting your own answer means if someone else gets the same issue they'll at least look at the possibility the SSD is failing.
1
Skygod68Sr. Systems AdministratorAuthor Commented:
I hate selecting myself for a solution but after really looking at the BIOS screen, I saw what was going on.   I rebooted 5-6 times and the HD would reappear in the BIOS.  Upon the next reboot, I went into the BIOS and the HD was missing again.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Operating Systems

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.