Unable to access vm console since vCenter 5.5 upgrade

Hello.

I have just upgraded my vCenter server from vSphere 5.1 to 5.5 update 3.  The problem I am having is that in most cases, console access to all vm's now no longer works.  I say most cases, as I can still access vm consoles from the vSphere client on my local machine and anyone can access the vm consoles from the vsphere client on the vCenter server itself; but when they try from elsewhere, e.g the vsphere client on their machines or from terminal servers they get the following errror:

Unable to connect to the MKS: Could not connect to pipe \\.\pipe\vmware-authdpipe within retry period

I have tried restarting hostd and vpxa agents on one of the hosts and putting another into maintenance mode and rebooting it, migrating a vm back on to the host but I still get the same error when trying to connect to the console of the vm.
carbonbaseAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
1. did you update the vSphere Client on terminal services ? and this involves, removing ALL the other vSphere Clients, and just install the client for 5.5 U3.

2. is it only this Terminal Server End Point which is affected ?

3. Is a firewall enabled and blocking ports ?

4. check DNS and FQDN, and Reverse DNS resolutions can be made from the Terminal Server to vCenter Server.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
carbonbaseAuthor Commented:
1. I've asked one of my colleagues to uninstall all vsphere clients from their local machine and install a copy which i downloaded from the upgraded vCenter server.

2. not just terminal server, also occurs on local Window 7 desktops (although not mine).

3. i think this may be the issue as my colleague has just tried from their desktop (wired lan connection) and it works, but it doesn't work from their (wireless lan connection) laptop.  Also works fine from some terminal servers but not all.

4. checked forward and revers DNS and all resolves fine, also flushed dns cache.

I'm going to get our network guys to check if there are any ports being blocked on the affected machines.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Always a good idea to make friends with Network Team and Manager
0
carbonbaseAuthor Commented:
This was firewall issue, seems to be working ok now.  Thanks for your help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.