Cisco 819 router LAN connection

Hi guys,
I was able to successfully configure a Cisco 819 router to have access to Verizon 4G LTE network.
This is that while connected to the console I can ping www.google.com successfully.

Now, I need to connect this router to my LAN (10.10.70.0/24).
So I assigned the router an IP to VLAN1 (10.10.70.254) and connected port 1 to one of the ports in my switch.

I can ping the router (10.10.70.254) from my LAN.
I can telnet the router from my LAN.

But the next step for me before I take it into production is to be able to navigate through the Verizon network using a computer.
To this end I configure a computer with the following:

IP: 10.10.70.249
GW: 10.10.70.254
DNS: 8.8.8.8

Again, from this computer I can ping the router (10.10.70.254)
I can telnet the router (10.10.70.254)

But I would think that because I have configured this router as my gateway in the PC all the PC's traffic would be forwarded to the router and the router would route that traffic to the Verizon network.
But no, my traffic can't get pass the router.

My question:
What am I missing here?
cargexAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JustInCaseCommented:
Did you create NAT rules?

You need to "mark" any inside and outside interfaces.
interface vlan 10
ip nat inside

interface vlan 20
ip nat inside

interface faX/X       (WAN interface)
ip nat outside

Also you need to create access-list to permit NAT of private to public addresses.
access-list 100 permit 10.0.0.0 0.255.255.255 any
and nat statement to perform natting
ip nat inside source list 100 interface faX/X overload (where X is outside interface

and you need default route on router
ip route 0.0.0.0 0.0.0.0 x.x.x.x    <--- x.x.x.x is ISPs router IP address (you can also use interface FaX/X, but it is a less desirable solution) ISP's IP address you should be able to find out by doing traceroute)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LB1234Commented:
Are you using a laptop to console into the router?  If so, was the connected to a working wifi connection during your test?
0
cargexAuthor Commented:
You are an absolute genius my friend.
This worked like a charm!!!!

Thank you very much!

:-)
0
JustInCaseCommented:
You're welcome.
;-)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.