Can't access RDS server from outside of the network.

OK, I'm at wits end.
Set up Remote Desktop Services on 2012 R2 (RD Connection Broker, RD gateway, RD Licensing, RD Session Host, RD We Access all on the same server). Setup a DNS A-record for remote.domain.com to point to a DynDNS account which points to the WAN on my firewall which then is NATed to the RDS server.  I know I am getting good connection from a browser from https://remote.domain.com to the RDS server as I confirmed it with "telnet remote.domain.com 443" but I do not get a telnet response on port 3389.

I configured both RD Web Access (for a single application and am currently bound to a self-signed certificate) and gateway and can access everything fine from the inside of the network using "https://rds.internal.domain.com/RDWeb" but when I try to access from the outside using "https://remote.domain.com" I get error 403 Forbidden - "You don't have permission to access / on this server".  I really need to get this set up so users can access the server from the outside.

Thank you in advance for your help with this matter!
ImImInAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
Have you tried changing authentication from Intgrated to Basic in IIS.
DrDave242Senior Support EngineerCommented:
...can access everything fine from the inside of the network using "https://rds.internal.domain.com/RDWeb" but when I try to access from the outside using "https://remote.domain.com" I get error 403 Forbidden
Do you mean that you're trying to access https://remote.domain.com/RDWeb from outside, or just https://remote.domain.com ?" If it's the latter, that's the problem. You have to specify the RDWeb virtual directory in the URL, or it's not going to work. If you are specifying RDWeb in the URL and it's still not working, check the properties of the site in IIS to make sure it has a host header that will accept requests for remote.domain.com as well as rds.internal.domain.com.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.